CVE-2025-24791 snowflake-connector-nodejs has incorrect validation of temporary credential cache file permissions

Medium 4.4 Published Updated

An attacker with local write access can bypass permission checks on the credential cache, potentially stealing credentials to access Snowflake accounts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-24791?

CVE-2025-24791 is a medium-severity vulnerability in snowflakedb snowflake-connector-nodejs, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

snowflake-connector-nodejs is a NodeJS driver for Snowflake. Snowflake discovered and remediated a vulnerability in the Snowflake NodeJS Driver. File permissions checks of the temporary credential cache could be bypassed by an attacker with write access to the local cache directory. This vulnerability affects versions 1.12.0 through 2.0.1 on Linux. Snowflake fixed the issue in version 2.0.2.

Weakness: CWE-281

Which versions are affected by CVE-2025-24791?

2 open source packages ship an affected version, including snowflake-sdk. It affects 1 product.

PackageAffectedFixed in
snowflake-sdk npmFrom 1.12.02.0.2
snowflake-sdk npmFrom 1.12.02.0.2

Products include Snowflake Snowflake Connector.

How do I fix CVE-2025-24791?

Upgrade snowflake-sdk to 2.0.2 or later.

Is CVE-2025-24791 being exploited?

There is no known exploitation of CVE-2025-24791 in the wild and no public exploit code.

Sources

Also known as GHSA-xfhv-wqj6-rx99.

Is CVE-2025-24791 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free