CVE-2025-24792 Snowflake PHP PDO Driver has a Signed-to-Unsigned Conversion Error
Executing unsupported PUT or GET queries on stages causes a signed-to-unsigned conversion error, crashing the application using the Snowflake PHP PDO Driver.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2025-24792?
CVE-2025-24792 is a medium-severity vulnerability in snowflakedb pdo_snowflake, published on 29 Jan 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Snowflake PHP PDO Driver is a driver that uses the PHP Data Objects (PDO) extension to connect to the Snowflake database. Snowflake discovered and remediated a vulnerability in the Snowflake PHP PDO Driver where executing unsupported queries like PUT or GET on stages causes a signed-to-unsigned conversion error that crashes the application using the Driver. This vulnerability affects versions 0.2.0 through 3.0.3. Snowflake fixed the issue in version 3.1.0.
Weakness: CWE-195
Which versions are affected by CVE-2025-24792?
How do I fix CVE-2025-24792?
No fix has been published for CVE-2025-24792 yet. Limit exposure of the affected software until one is available.
Is CVE-2025-24792 being exploited?
There is no known exploitation of CVE-2025-24792 in the wild and no public exploit code.
Sources
Also known as GHSA-f8q2-7fv5-cg93.