{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-24792 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-24792 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-24792 is a medium-severity vulnerability in snowflakedb pdo_snowflake, published on 29 Jan 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-24792 and fix it if it is affected.\n\nWhat it is: CVE-2025-24792 is a medium-severity vulnerability in snowflakedb pdo_snowflake, published on 29 Jan 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-24792 in the wild and no public exploit code.\n\nAffected product: snowflakedb pdo_snowflake. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24792/ (Markdown: https://insights.sbomify.com/CVE-2025-24792/index.md)","id":"CVE-2025-24792","markdown":"https://insights.sbomify.com/CVE-2025-24792/index.md","name":"CVE-2025-24792","record":{"aliases":["GHSA-f8q2-7fv5-cg93"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Snowflake PHP PDO Driver","requires_auth":"low_privilege","summary":"Executing unsupported PUT or GET queries on stages causes a signed-to-unsigned conversion error, crashing the application using the Snowflake PHP PDO Driver.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-195","name":"Signed to Unsigned Conversion Error"}],"description":"Snowflake PHP PDO Driver is a driver that uses the PHP Data Objects (PDO) extension to connect to the Snowflake database. Snowflake discovered and remediated a vulnerability in the Snowflake PHP PDO Driver where executing unsupported queries like PUT or GET on stages causes a signed-to-unsigned conversion error that crashes the application using the Driver. This vulnerability affects versions 0.2.0 through 3.0.3. Snowflake fixed the issue in version 3.1.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Snowflake PHP PDO Driver has a Signed-to-Unsigned Conversion Error","id":"CVE-2025-24792","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"Snowflake Connector for Python has an SQL Injection in write_pandas","id":"CVE-2025-24793"},"packages":[],"prev":{"headline":"snowflake-connector-nodejs has incorrect validation of temporary credential cache file permissions","id":"CVE-2025-24791"},"products":["pdo_snowflake"],"published":"2025-01-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-12","vendors":["snowflakedb"]},"summary":"Executing unsupported PUT or GET queries on stages causes a signed-to-unsigned conversion error, crashing the application using the Snowflake PHP PDO Driver.","url":"https://insights.sbomify.com/CVE-2025-24792/"}