# CVE-2025-24792: Snowflake PHP PDO Driver has a Signed-to-Unsigned Conversion Error

> Executing unsupported PUT or GET queries on stages causes a signed-to-unsigned conversion error, crashing the application using the Snowflake PHP PDO Driver.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 29 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-f8q2-7fv5-cg93

## What is CVE-2025-24792?

CVE-2025-24792 is a medium-severity vulnerability in snowflakedb pdo_snowflake, published on 29 Jan 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Snowflake PHP PDO Driver is a driver that uses the PHP Data Objects (PDO) extension to connect to the Snowflake database. Snowflake discovered and remediated a vulnerability in the Snowflake PHP PDO Driver where executing unsupported queries like PUT or GET on stages causes a signed-to-unsigned conversion error that crashes the application using the Driver. This vulnerability affects versions 0.2.0 through 3.0.3. Snowflake fixed the issue in version 3.1.0.

Weakness: CWE-195 (Signed to Unsigned Conversion Error)

## Which versions are affected by CVE-2025-24792?


## How do I fix CVE-2025-24792?

No fix has been published for CVE-2025-24792 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-24792 being exploited?

There is no known exploitation of CVE-2025-24792 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24792 and fix it if it is affected.

What it is: CVE-2025-24792 is a medium-severity vulnerability in snowflakedb pdo_snowflake, published on 29 Jan 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-24792 in the wild and no public exploit code.

Affected product: snowflakedb pdo_snowflake. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24792/ (Markdown: https://insights.sbomify.com/CVE-2025-24792/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24792
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24792
- OSV: https://osv.dev/vulnerability/CVE-2025-24792

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24792/
Summaries are generated and may contain mistakes; the official description above is the record.
