CVE-2025-24793 Snowflake Connector for Python has an SQL Injection in write_pandas
An SQL injection vulnerability in the write_pandas function allows attackers to manipulate database queries, requiring users to upgrade the Snowflake Connector for Python.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-24793?
CVE-2025-24793 is a high-severity SQL injection vulnerability in snowflakedb snowflake-connector-python, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. A function from the snowflake.connector.pandas_tools module is vulnerable to SQL injection. This vulnerability affects versions 2.2.5 through 3.13.0. Snowflake fixed the issue in version 3.13.1.
Weakness: CWE-89
Which versions are affected by CVE-2025-24793?
3 open source packages ship an affected version, including snowflake-connector-python. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
snowflake-connector-python PyPI | From 2.2.5 | 3.13.1 |
snowflake-connector-python PyPI | From 2.2.5 | 3.13.1 |
snowflake-connector-python PyPI | From 2.2.5 | 3.13.1 |
Products include Snowflake Snowflake Connector.
How do I fix CVE-2025-24793?
Upgrade snowflake-connector-python to 3.13.1 or later.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2025-24793 being exploited?
There is no known exploitation of CVE-2025-24793 in the wild and no public exploit code.
Other vulnerabilities in snowflakedb snowflake-connector-python
- CVE-2023-34230 Snowflake Connector vulnerable to Command Injection
- CVE-2023-34232 Snowflake NodeJS Driver vulnerable to Command Injection
- CVE-2023-34233 Snowflake Python Connector vulnerable to Command Injection
- CVE-2025-24794 The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache
- CVE-2023-51662 Snowflake Connector .NET does not properly check the Certificate Revocation List (CRL)
Sources
Also known as ECHO-37f7-b437-77a2, GHSA-2vpq-fh52-j3wv, MINI-vfwv-jfvv-vqfc, PYSEC-2025-26, ROOT-APP-PYPI-CVE-2025-24793.