{"answers":{"affected":"3 open source packages ship an affected version, including snowflake-connector-python. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-24793 in the wild and no public exploit code.","fix":"Upgrade snowflake-connector-python to 3.13.1 or later.","what":"CVE-2025-24793 is a high-severity SQL injection vulnerability in snowflakedb snowflake-connector-python, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24793 and fix it if it is affected.\n\nWhat it is: CVE-2025-24793 is a high-severity SQL injection vulnerability in snowflakedb snowflake-connector-python, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24793 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- snowflake-connector-python (PyPI): affected from 2.2.5; fixed in 3.13.1\n- snowflake-connector-python (PyPI): affected from 2.2.5; fixed in 3.13.1\n- snowflake-connector-python (PyPI): affected from 2.2.5; fixed in 3.13.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24793/ (Markdown: https://insights.sbomify.com/CVE-2025-24793/index.md)","id":"CVE-2025-24793","markdown":"https://insights.sbomify.com/CVE-2025-24793/index.md","name":"CVE-2025-24793","record":{"aliases":["ECHO-37f7-b437-77a2","GHSA-2vpq-fh52-j3wv","MINI-vfwv-jfvv-vqfc","PYSEC-2025-26","ROOT-APP-PYPI-CVE-2025-24793"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Snowflake Python connector","requires_auth":"low_privilege","summary":"An SQL injection vulnerability in the write_pandas function allows attackers to manipulate database queries, requiring users to upgrade the Snowflake Connector for Python.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"snowflake_connector","vendor":"snowflake"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. A function from the snowflake.connector.pandas_tools module is vulnerable to SQL injection. This vulnerability affects versions 2.2.5 through 3.13.0. Snowflake fixed the issue in version 3.13.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Snowflake Connector for Python has an SQL Injection in write_pandas","id":"CVE-2025-24793","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache","id":"CVE-2025-24794"},"packages":[{"ecosystem":"PyPI","fixed":["3.13.1"],"introduced":["2.2.5"],"last_affected":[],"package":"snowflake-connector-python","purl":null,"source":"GHSA-2vpq-fh52-j3wv"},{"ecosystem":"PyPI","fixed":["3.13.1"],"introduced":["2.2.5"],"last_affected":[],"package":"snowflake-connector-python","purl":"pkg:pypi/snowflake-connector-python","source":"GHSA-2vpq-fh52-j3wv"},{"ecosystem":"PyPI","fixed":["3.13.1"],"introduced":["2.2.5"],"last_affected":[],"package":"snowflake-connector-python","purl":"pkg:pypi/snowflake-connector-python","source":"PYSEC-2025-26"}],"prev":{"headline":"Snowflake PHP PDO Driver has a Signed-to-Unsigned Conversion Error","id":"CVE-2025-24792"},"products":["snowflake-connector-python"],"published":"2025-01-29","related":[{"cvss_score":7.3,"headline":"Snowflake Connector vulnerable to Command Injection","id":"CVE-2023-34230","kev_date_added":null,"published":"2023-06-08"},{"cvss_score":7.3,"headline":"Snowflake NodeJS Driver vulnerable to Command Injection","id":"CVE-2023-34232","kev_date_added":null,"published":"2023-06-08"},{"cvss_score":7.3,"headline":"Snowflake Python Connector vulnerable to Command Injection","id":"CVE-2023-34233","kev_date_added":null,"published":"2023-06-08"},{"cvss_score":6.7,"headline":"The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache","id":"CVE-2025-24794","kev_date_added":null,"published":"2025-01-29"},{"cvss_score":6,"headline":"Snowflake Connector .NET does not properly check the Certificate Revocation List (CRL)","id":"CVE-2023-51662","kev_date_added":null,"published":"2023-12-22"},{"cvss_score":5.5,"headline":"Snowflake Connector for Python has sensitive data in logs","id":"CVE-2024-49750","kev_date_added":null,"published":"2024-10-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-31","vendors":["snowflakedb"]},"summary":"An SQL injection vulnerability in the write_pandas function allows attackers to manipulate database queries, requiring users to upgrade the Snowflake Connector for Python.","url":"https://insights.sbomify.com/CVE-2025-24793/"}