# CVE-2025-24793: Snowflake Connector for Python has an SQL Injection in write_pandas

> An SQL injection vulnerability in the write_pandas function allows attackers to manipulate database queries, requiring users to upgrade the Snowflake Connector for Python.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2025
- **Updated:** 31 Jan 2025
- **Also known as:** ECHO-37f7-b437-77a2, GHSA-2vpq-fh52-j3wv, MINI-vfwv-jfvv-vqfc, PYSEC-2025-26, ROOT-APP-PYPI-CVE-2025-24793

## What is CVE-2025-24793?

CVE-2025-24793 is a high-severity SQL injection vulnerability in snowflakedb snowflake-connector-python, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. A function from the snowflake.connector.pandas_tools module is vulnerable to SQL injection. This vulnerability affects versions 2.2.5 through 3.13.0. Snowflake fixed the issue in version 3.13.1.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-24793?

3 open source packages ship an affected version, including snowflake-connector-python. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snowflake-connector-python` | PyPI | From 2.2.5 | 3.13.1 |
| `snowflake-connector-python` | PyPI | From 2.2.5 | 3.13.1 |
| `snowflake-connector-python` | PyPI | From 2.2.5 | 3.13.1 |

Products: Snowflake Snowflake Connector.

## How do I fix CVE-2025-24793?

Upgrade snowflake-connector-python to 3.13.1 or later.

## Is CVE-2025-24793 being exploited?

There is no known exploitation of CVE-2025-24793 in the wild and no public exploit code.

## Other vulnerabilities in snowflakedb snowflake-connector-python

- [CVE-2023-34230](https://insights.sbomify.com/CVE-2023-34230/): Snowflake Connector vulnerable to Command Injection (high 7.3)
- [CVE-2023-34232](https://insights.sbomify.com/CVE-2023-34232/): Snowflake NodeJS Driver vulnerable to Command Injection (high 7.3)
- [CVE-2023-34233](https://insights.sbomify.com/CVE-2023-34233/): Snowflake Python Connector vulnerable to Command Injection (high 7.3)
- [CVE-2025-24794](https://insights.sbomify.com/CVE-2025-24794/): The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache (medium 6.7)
- [CVE-2023-51662](https://insights.sbomify.com/CVE-2023-51662/): Snowflake Connector .NET does not properly check the Certificate Revocation List (CRL) (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24793 and fix it if it is affected.

What it is: CVE-2025-24793 is a high-severity SQL injection vulnerability in snowflakedb snowflake-connector-python, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24793 in the wild and no public exploit code.

Affected packages and fixed versions:
- snowflake-connector-python (PyPI): affected from 2.2.5; fixed in 3.13.1
- snowflake-connector-python (PyPI): affected from 2.2.5; fixed in 3.13.1
- snowflake-connector-python (PyPI): affected from 2.2.5; fixed in 3.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24793/ (Markdown: https://insights.sbomify.com/CVE-2025-24793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24793
- OSV: https://osv.dev/vulnerability/CVE-2025-24793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24793/
Summaries are generated and may contain mistakes; the official description above is the record.
