CVE-2025-24794 The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache
Insecure pickle deserialization in the OCSP cache allows local attackers to escalate privileges in applications using the Snowflake Python connector.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-24794?
CVE-2025-24794 is a medium-severity unsafe deserialization vulnerability in snowflakedb snowflake-connector-python, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. The OCSP response cache uses pickle as the serialization format, potentially leading to local privilege escalation. This vulnerability affects versions 2.7.12 through 3.13.0. Snowflake fixed the issue in version 3.13.1.
Weakness: CWE-502
Which versions are affected by CVE-2025-24794?
3 open source packages ship an affected version, including snowflake-connector-python. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
snowflake-connector-python PyPI | From 2.7.12 | 3.13.1 |
snowflake-connector-python PyPI | From 2.7.12 | 3.13.1 |
snowflake-connector-python PyPI | From 2.7.12 | 3.13.1 |
Products include Snowflake Snowflake Connector.
How do I fix CVE-2025-24794?
Upgrade snowflake-connector-python to 3.13.1 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2025-24794 being exploited?
There is no known exploitation of CVE-2025-24794 in the wild and no public exploit code.
Other vulnerabilities in snowflakedb snowflake-connector-python
- CVE-2023-34230 Snowflake Connector vulnerable to Command Injection
- CVE-2023-34232 Snowflake NodeJS Driver vulnerable to Command Injection
- CVE-2023-34233 Snowflake Python Connector vulnerable to Command Injection
- CVE-2025-24793 Snowflake Connector for Python has an SQL Injection in write_pandas
- CVE-2023-51662 Snowflake Connector .NET does not properly check the Certificate Revocation List (CRL)
Sources
Also known as ECHO-683f-d6fb-ce4f, GHSA-m4f6-vcj4-w5mx, MINI-24q8-vg58-89j6, PYSEC-2025-27.