{"answers":{"affected":"3 open source packages ship an affected version, including snowflake-connector-python. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-24794 in the wild and no public exploit code.","fix":"Upgrade snowflake-connector-python to 3.13.1 or later.","what":"CVE-2025-24794 is a medium-severity unsafe deserialization vulnerability in snowflakedb snowflake-connector-python, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24794 and fix it if it is affected.\n\nWhat it is: CVE-2025-24794 is a medium-severity unsafe deserialization vulnerability in snowflakedb snowflake-connector-python, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24794 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- snowflake-connector-python (PyPI): affected from 2.7.12; fixed in 3.13.1\n- snowflake-connector-python (PyPI): affected from 2.7.12; fixed in 3.13.1\n- snowflake-connector-python (PyPI): affected from 2.7.12; fixed in 3.13.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24794/ (Markdown: https://insights.sbomify.com/CVE-2025-24794/index.md)","id":"CVE-2025-24794","markdown":"https://insights.sbomify.com/CVE-2025-24794/index.md","name":"CVE-2025-24794","record":{"aliases":["ECHO-683f-d6fb-ce4f","GHSA-m4f6-vcj4-w5mx","MINI-24q8-vg58-89j6","PYSEC-2025-27"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python database connector","requires_auth":"high_privilege","summary":"Insecure pickle deserialization in the OCSP cache allows local attackers to escalate privileges in applications using the Snowflake Python connector.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"snowflake_connector","vendor":"snowflake"}],"cvss":{"score":6.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. The OCSP response cache uses pickle as the serialization format, potentially leading to local privilege escalation. This vulnerability affects versions 2.7.12 through 3.13.0. Snowflake fixed the issue in version 3.13.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache","id":"CVE-2025-24794","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"The Snowflake Connector for Python uses insecure cache files permissions","id":"CVE-2025-24795"},"packages":[{"ecosystem":"PyPI","fixed":["3.13.1"],"introduced":["2.7.12"],"last_affected":[],"package":"snowflake-connector-python","purl":null,"source":"GHSA-m4f6-vcj4-w5mx"},{"ecosystem":"PyPI","fixed":["3.13.1"],"introduced":["2.7.12"],"last_affected":[],"package":"snowflake-connector-python","purl":"pkg:pypi/snowflake-connector-python","source":"GHSA-m4f6-vcj4-w5mx"},{"ecosystem":"PyPI","fixed":["3.13.1"],"introduced":["2.7.12"],"last_affected":[],"package":"snowflake-connector-python","purl":"pkg:pypi/snowflake-connector-python","source":"PYSEC-2025-27"}],"prev":{"headline":"Snowflake Connector for Python has an SQL Injection in write_pandas","id":"CVE-2025-24793"},"products":["snowflake-connector-python"],"published":"2025-01-29","related":[{"cvss_score":7.3,"headline":"Snowflake Connector vulnerable to Command Injection","id":"CVE-2023-34230","kev_date_added":null,"published":"2023-06-08"},{"cvss_score":7.3,"headline":"Snowflake NodeJS Driver vulnerable to Command Injection","id":"CVE-2023-34232","kev_date_added":null,"published":"2023-06-08"},{"cvss_score":7.3,"headline":"Snowflake Python Connector vulnerable to Command Injection","id":"CVE-2023-34233","kev_date_added":null,"published":"2023-06-08"},{"cvss_score":7,"headline":"Snowflake Connector for Python has an SQL Injection in write_pandas","id":"CVE-2025-24793","kev_date_added":null,"published":"2025-01-29"},{"cvss_score":6,"headline":"Snowflake Connector .NET does not properly check the Certificate Revocation List (CRL)","id":"CVE-2023-51662","kev_date_added":null,"published":"2023-12-22"},{"cvss_score":5.5,"headline":"Snowflake Connector for Python has sensitive data in logs","id":"CVE-2024-49750","kev_date_added":null,"published":"2024-10-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-31","vendors":["snowflakedb"]},"summary":"Insecure pickle deserialization in the OCSP cache allows local attackers to escalate privileges in applications using the Snowflake Python connector.","url":"https://insights.sbomify.com/CVE-2025-24794/"}