# CVE-2025-24794: The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache

> Insecure pickle deserialization in the OCSP cache allows local attackers to escalate privileges in applications using the Snowflake Python connector.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2025
- **Updated:** 31 Jan 2025
- **Also known as:** ECHO-683f-d6fb-ce4f, GHSA-m4f6-vcj4-w5mx, MINI-24q8-vg58-89j6, PYSEC-2025-27

## What is CVE-2025-24794?

CVE-2025-24794 is a medium-severity unsafe deserialization vulnerability in snowflakedb snowflake-connector-python, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. The OCSP response cache uses pickle as the serialization format, potentially leading to local privilege escalation. This vulnerability affects versions 2.7.12 through 3.13.0. Snowflake fixed the issue in version 3.13.1.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-24794?

3 open source packages ship an affected version, including snowflake-connector-python. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snowflake-connector-python` | PyPI | From 2.7.12 | 3.13.1 |
| `snowflake-connector-python` | PyPI | From 2.7.12 | 3.13.1 |
| `snowflake-connector-python` | PyPI | From 2.7.12 | 3.13.1 |

Products: Snowflake Snowflake Connector.

## How do I fix CVE-2025-24794?

Upgrade snowflake-connector-python to 3.13.1 or later.

## Is CVE-2025-24794 being exploited?

There is no known exploitation of CVE-2025-24794 in the wild and no public exploit code.

## Other vulnerabilities in snowflakedb snowflake-connector-python

- [CVE-2023-34230](https://insights.sbomify.com/CVE-2023-34230/): Snowflake Connector vulnerable to Command Injection (high 7.3)
- [CVE-2023-34232](https://insights.sbomify.com/CVE-2023-34232/): Snowflake NodeJS Driver vulnerable to Command Injection (high 7.3)
- [CVE-2023-34233](https://insights.sbomify.com/CVE-2023-34233/): Snowflake Python Connector vulnerable to Command Injection (high 7.3)
- [CVE-2025-24793](https://insights.sbomify.com/CVE-2025-24793/): Snowflake Connector for Python has an SQL Injection in write_pandas (high 7.0)
- [CVE-2023-51662](https://insights.sbomify.com/CVE-2023-51662/): Snowflake Connector .NET does not properly check the Certificate Revocation List (CRL) (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24794 and fix it if it is affected.

What it is: CVE-2025-24794 is a medium-severity unsafe deserialization vulnerability in snowflakedb snowflake-connector-python, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24794 in the wild and no public exploit code.

Affected packages and fixed versions:
- snowflake-connector-python (PyPI): affected from 2.7.12; fixed in 3.13.1
- snowflake-connector-python (PyPI): affected from 2.7.12; fixed in 3.13.1
- snowflake-connector-python (PyPI): affected from 2.7.12; fixed in 3.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24794/ (Markdown: https://insights.sbomify.com/CVE-2025-24794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24794
- OSV: https://osv.dev/vulnerability/CVE-2025-24794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24794/
Summaries are generated and may contain mistakes; the official description above is the record.
