# CVE-2025-24795: The Snowflake Connector for Python uses insecure cache files permissions

> Local attackers can read cached Snowflake credentials from world-readable files on Linux when temporary caching is enabled.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2025
- **Updated:** 31 Jan 2025
- **Also known as:** ECHO-83e7-e40a-49ea, GHSA-r2x6-cjg7-8r43, MINI-837h-67rh-j3wj, PYSEC-2025-28

## What is CVE-2025-24795?

CVE-2025-24795 is a medium-severity vulnerability in snowflakedb snowflake-connector-python, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. On Linux systems, when temporary credential caching is enabled, the Snowflake Connector for Python will cache temporary credentials locally in a world-readable file. This vulnerability affects versions 2.3.7 through 3.13.0. Snowflake fixed the issue in version 3.13.1.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2025-24795?

3 open source packages ship an affected version, including snowflake-connector-python. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snowflake-connector-python` | PyPI | From 2.3.7 | 3.13.1 |
| `snowflake-connector-python` | PyPI | From 2.3.7 | 3.13.1 |
| `snowflake-connector-python` | PyPI | From 2.3.7 | 3.13.1 |

Products: Snowflake Snowflake Connector.

## How do I fix CVE-2025-24795?

Upgrade snowflake-connector-python to 3.13.1 or later.

## Is CVE-2025-24795 being exploited?

There is no known exploitation of CVE-2025-24795 in the wild and no public exploit code.

## Other vulnerabilities in snowflakedb snowflake-connector-python

- [CVE-2023-34230](https://insights.sbomify.com/CVE-2023-34230/): Snowflake Connector vulnerable to Command Injection (high 7.3)
- [CVE-2023-34232](https://insights.sbomify.com/CVE-2023-34232/): Snowflake NodeJS Driver vulnerable to Command Injection (high 7.3)
- [CVE-2023-34233](https://insights.sbomify.com/CVE-2023-34233/): Snowflake Python Connector vulnerable to Command Injection (high 7.3)
- [CVE-2025-24793](https://insights.sbomify.com/CVE-2025-24793/): Snowflake Connector for Python has an SQL Injection in write_pandas (high 7.0)
- [CVE-2025-24794](https://insights.sbomify.com/CVE-2025-24794/): The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache (medium 6.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24795 and fix it if it is affected.

What it is: CVE-2025-24795 is a medium-severity vulnerability in snowflakedb snowflake-connector-python, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24795 in the wild and no public exploit code.

Affected packages and fixed versions:
- snowflake-connector-python (PyPI): affected from 2.3.7; fixed in 3.13.1
- snowflake-connector-python (PyPI): affected from 2.3.7; fixed in 3.13.1
- snowflake-connector-python (PyPI): affected from 2.3.7; fixed in 3.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24795/ (Markdown: https://insights.sbomify.com/CVE-2025-24795/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24795
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24795
- OSV: https://osv.dev/vulnerability/CVE-2025-24795

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24795/
Summaries are generated and may contain mistakes; the official description above is the record.
