CVE-2025-24800 Critical vulnerability in `ismp-grandpa` <v15.0.1

Critical 9.3 Published Updated

A flaw in the ismp-grandpa crate allows attackers to forge finality proofs, potentially stealing funds or compromising cross-chain applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-24800?

CVE-2025-24800 is a critical vulnerability in polytope-labs hyperbridge, published on 28 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Hyperbridge is a hyper-scalable coprocessor for verifiable, cross-chain interoperability. A critical vulnerability was discovered in the ismp-grandpa crate, that allowed a malicious prover easily convince the verifier of the finality of arbitrary headers. This could be used to steal funds or compromise other kinds of cross-chain applications. This vulnerability is fixed in 15.0.1.

Weakness: CWE-670, CWE-347

Which versions are affected by CVE-2025-24800?

6 open source packages ship an affected version, including grandpa-verifier, grandpa-verifier-primitives and ismp-grandpa.

PackageAffectedFixed in
grandpa-verifier crates.ioAll versions0.1.2
grandpa-verifier crates.ioAll versions0.1.2
grandpa-verifier-primitives crates.ioAll versions0.1.2
grandpa-verifier-primitives crates.ioAll versions0.1.2
ismp-grandpa crates.ioAll versions15.0.1
ismp-grandpa crates.ioAll versions15.0.1

How do I fix CVE-2025-24800?

Upgrade grandpa-verifier to 0.1.2 or later.

Is CVE-2025-24800 being exploited?

There is no known exploitation of CVE-2025-24800 in the wild and no public exploit code.

Sources

Also known as GHSA-wwx5-gpgr-vxr7.

Is CVE-2025-24800 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free