{"answers":{"affected":"6 open source packages ship an affected version, including grandpa-verifier, grandpa-verifier-primitives and ismp-grandpa.","exploited":"There is no known exploitation of CVE-2025-24800 in the wild and no public exploit code.","fix":"Upgrade grandpa-verifier to 0.1.2 or later.","what":"CVE-2025-24800 is a critical vulnerability in polytope-labs hyperbridge, published on 28 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24800 and fix it if it is affected.\n\nWhat it is: CVE-2025-24800 is a critical vulnerability in polytope-labs hyperbridge, published on 28 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24800 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- grandpa-verifier (crates.io): affected all versions; fixed in 0.1.2\n- grandpa-verifier (crates.io): affected all versions; fixed in 0.1.2\n- grandpa-verifier-primitives (crates.io): affected all versions; fixed in 0.1.2\n- grandpa-verifier-primitives (crates.io): affected all versions; fixed in 0.1.2\n- ismp-grandpa (crates.io): affected all versions; fixed in 15.0.1\n- ismp-grandpa (crates.io): affected all versions; fixed in 15.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24800/ (Markdown: https://insights.sbomify.com/CVE-2025-24800/index.md)","id":"CVE-2025-24800","markdown":"https://insights.sbomify.com/CVE-2025-24800/index.md","name":"CVE-2025-24800","record":{"aliases":["GHSA-wwx5-gpgr-vxr7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Hyperbridge Rust crate","requires_auth":"none","summary":"A flaw in the ismp-grandpa crate allows attackers to forge finality proofs, potentially stealing funds or compromising cross-chain applications.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-670","name":"Always-Incorrect Control Flow Implementation"},{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"Hyperbridge is a hyper-scalable coprocessor for verifiable, cross-chain interoperability. A critical vulnerability was discovered in the ismp-grandpa crate, that allowed a malicious prover easily convince the verifier of the finality of arbitrary headers. This could be used to steal funds or compromise other kinds of cross-chain applications. This vulnerability is fixed in 15.0.1.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Critical vulnerability in `ismp-grandpa` \u003cv15.0.1","id":"CVE-2025-24800","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"other","year":"2025"},"n_packages":6,"n_references":3,"next":{"headline":"GLPI allows authenticated remote code execution","id":"CVE-2025-24801"},"packages":[{"ecosystem":"crates.io","fixed":["0.1.2"],"introduced":["0"],"last_affected":[],"package":"grandpa-verifier","purl":null,"source":"GHSA-wwx5-gpgr-vxr7"},{"ecosystem":"crates.io","fixed":["0.1.2"],"introduced":["0"],"last_affected":[],"package":"grandpa-verifier","purl":"pkg:cargo/grandpa-verifier","source":"GHSA-wwx5-gpgr-vxr7"},{"ecosystem":"crates.io","fixed":["0.1.2"],"introduced":["0"],"last_affected":[],"package":"grandpa-verifier-primitives","purl":null,"source":"GHSA-wwx5-gpgr-vxr7"},{"ecosystem":"crates.io","fixed":["0.1.2"],"introduced":["0"],"last_affected":[],"package":"grandpa-verifier-primitives","purl":"pkg:cargo/grandpa-verifier-primitives","source":"GHSA-wwx5-gpgr-vxr7"},{"ecosystem":"crates.io","fixed":["15.0.1"],"introduced":["0"],"last_affected":[],"package":"ismp-grandpa","purl":null,"source":"GHSA-wwx5-gpgr-vxr7"},{"ecosystem":"crates.io","fixed":["15.0.1"],"introduced":["0"],"last_affected":[],"package":"ismp-grandpa","purl":"pkg:cargo/ismp-grandpa","source":"GHSA-wwx5-gpgr-vxr7"}],"prev":{"headline":"GLPI allows unauthenticated SQL injection through the inventory endpoint","id":"CVE-2025-24799"},"products":["hyperbridge"],"published":"2025-01-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-28","vendors":["polytope-labs"]},"summary":"A flaw in the ismp-grandpa crate allows attackers to forge finality proofs, potentially stealing funds or compromising cross-chain applications.","url":"https://insights.sbomify.com/CVE-2025-24800/"}