# CVE-2025-24800: Critical vulnerability in `ismp-grandpa` <v15.0.1

> A flaw in the ismp-grandpa crate allows attackers to forge finality proofs, potentially stealing funds or compromising cross-chain applications.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2025
- **Updated:** 28 Jan 2025
- **Also known as:** GHSA-wwx5-gpgr-vxr7

## What is CVE-2025-24800?

CVE-2025-24800 is a critical vulnerability in polytope-labs hyperbridge, published on 28 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hyperbridge is a hyper-scalable coprocessor for verifiable, cross-chain interoperability. A critical vulnerability was discovered in the ismp-grandpa crate, that allowed a malicious prover easily convince the verifier of the finality of arbitrary headers. This could be used to steal funds or compromise other kinds of cross-chain applications. This vulnerability is fixed in 15.0.1.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation), CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-24800?

6 open source packages ship an affected version, including grandpa-verifier, grandpa-verifier-primitives and ismp-grandpa.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grandpa-verifier` | crates.io | All versions | 0.1.2 |
| `grandpa-verifier` | crates.io | All versions | 0.1.2 |
| `grandpa-verifier-primitives` | crates.io | All versions | 0.1.2 |
| `grandpa-verifier-primitives` | crates.io | All versions | 0.1.2 |
| `ismp-grandpa` | crates.io | All versions | 15.0.1 |
| `ismp-grandpa` | crates.io | All versions | 15.0.1 |

## How do I fix CVE-2025-24800?

Upgrade grandpa-verifier to 0.1.2 or later.

## Is CVE-2025-24800 being exploited?

There is no known exploitation of CVE-2025-24800 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24800 and fix it if it is affected.

What it is: CVE-2025-24800 is a critical vulnerability in polytope-labs hyperbridge, published on 28 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24800 in the wild and no public exploit code.

Affected packages and fixed versions:
- grandpa-verifier (crates.io): affected all versions; fixed in 0.1.2
- grandpa-verifier (crates.io): affected all versions; fixed in 0.1.2
- grandpa-verifier-primitives (crates.io): affected all versions; fixed in 0.1.2
- grandpa-verifier-primitives (crates.io): affected all versions; fixed in 0.1.2
- ismp-grandpa (crates.io): affected all versions; fixed in 15.0.1
- ismp-grandpa (crates.io): affected all versions; fixed in 15.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24800/ (Markdown: https://insights.sbomify.com/CVE-2025-24800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24800
- OSV: https://osv.dev/vulnerability/CVE-2025-24800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24800/
Summaries are generated and may contain mistakes; the official description above is the record.
