{"answers":{"affected":"2 open source packages ship an affected version, including plonky2.","exploited":"There is no known exploitation of CVE-2025-24802 in the wild and no public exploit code.","fix":"Upgrade plonky2 to 1.0.1 or later.","what":"CVE-2025-24802 is a high-severity vulnerability in 0xPolygonZero plonky2, published on 30 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24802 and fix it if it is affected.\n\nWhat it is: CVE-2025-24802 is a high-severity vulnerability in 0xPolygonZero plonky2, published on 30 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24802 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- plonky2 (crates.io): affected from 1.0.0; fixed in 1.0.1\n- plonky2 (crates.io): affected from 1.0.0; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24802/ (Markdown: https://insights.sbomify.com/CVE-2025-24802/index.md)","id":"CVE-2025-24802","markdown":"https://insights.sbomify.com/CVE-2025-24802/index.md","name":"CVE-2025-24802","record":{"aliases":["GHSA-hj49-h7fq-px5h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"ZK-SNARK library","requires_auth":"none","summary":"A malicious prover can forge proofs for lookup tables not divisible by 26, bypassing cryptographic soundness in Plonky2 SNARKs.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-1240","name":"Use of a Cryptographic Primitive with a Risky Implementation"}],"description":"Plonky2 is a SNARK implementation based on techniques from PLONK and FRI. Lookup tables, whose length is not divisible by 26 = floor(num_routed_wires / 3) always include the 0 -\u003e 0 input-output pair. Thus a malicious prover can always prove that f(0) = 0 for any lookup table f (unless its length happens to be divisible by 26). The cause of problem is that the LookupTableGate-s are padded with zeros. A workaround from the user side is to extend the table (by repeating some entries) so that its length becomes divisible by 26. This vulnerability is fixed in 1.0.1.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Soundness issue with Plonky2 look up tables","id":"CVE-2025-24802","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"other","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Stored Cross-Site Scripting (XSS) in MobSF","id":"CVE-2025-24803"},"packages":[{"ecosystem":"crates.io","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"plonky2","purl":null,"source":"GHSA-hj49-h7fq-px5h"},{"ecosystem":"crates.io","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"plonky2","purl":"pkg:cargo/plonky2","source":"GHSA-hj49-h7fq-px5h"}],"prev":{"headline":"GLPI allows authenticated remote code execution","id":"CVE-2025-24801"},"products":["plonky2"],"published":"2025-01-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-30","vendors":["0xPolygonZero"]},"summary":"A malicious prover can forge proofs for lookup tables not divisible by 26, bypassing cryptographic soundness in Plonky2 SNARKs.","url":"https://insights.sbomify.com/CVE-2025-24802/"}