# CVE-2025-24802: Soundness issue with Plonky2 look up tables

> A malicious prover can forge proofs for lookup tables not divisible by 26, bypassing cryptographic soundness in Plonky2 SNARKs.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2025
- **Updated:** 30 Jan 2025
- **Also known as:** GHSA-hj49-h7fq-px5h

## What is CVE-2025-24802?

CVE-2025-24802 is a high-severity vulnerability in 0xPolygonZero plonky2, published on 30 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Plonky2 is a SNARK implementation based on techniques from PLONK and FRI. Lookup tables, whose length is not divisible by 26 = floor(num_routed_wires / 3) always include the 0 -> 0 input-output pair. Thus a malicious prover can always prove that f(0) = 0 for any lookup table f (unless its length happens to be divisible by 26). The cause of problem is that the LookupTableGate-s are padded with zeros. A workaround from the user side is to extend the table (by repeating some entries) so that its length becomes divisible by 26. This vulnerability is fixed in 1.0.1.

Weakness: CWE-1240 (Use of a Cryptographic Primitive with a Risky Implementation)

## Which versions are affected by CVE-2025-24802?

2 open source packages ship an affected version, including plonky2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plonky2` | crates.io | From 1.0.0 | 1.0.1 |
| `plonky2` | crates.io | From 1.0.0 | 1.0.1 |

## How do I fix CVE-2025-24802?

Upgrade plonky2 to 1.0.1 or later.

## Is CVE-2025-24802 being exploited?

There is no known exploitation of CVE-2025-24802 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24802 and fix it if it is affected.

What it is: CVE-2025-24802 is a high-severity vulnerability in 0xPolygonZero plonky2, published on 30 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24802 in the wild and no public exploit code.

Affected packages and fixed versions:
- plonky2 (crates.io): affected from 1.0.0; fixed in 1.0.1
- plonky2 (crates.io): affected from 1.0.0; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24802/ (Markdown: https://insights.sbomify.com/CVE-2025-24802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24802
- OSV: https://osv.dev/vulnerability/CVE-2025-24802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24802/
Summaries are generated and may contain mistakes; the official description above is the record.
