# CVE-2025-24803: Stored Cross-Site Scripting (XSS) in MobSF

> Attackers can inject malicious scripts via unsanitized bundle IDs in MobSF, potentially compromising user sessions or executing code.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Feb 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-cxqq-w3x5-7ph3, PYSEC-2026-1673

## What is CVE-2025-24803?

CVE-2025-24803 is a high-severity cross-site scripting vulnerability in Mobile-Security-Framework-MobSF, published on 5 Feb 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Mobile Security Framework (MobSF) is an automated, all-in-one mobile application (Android/iOS/Windows) pen-testing, malware analysis and security assessment framework. According to Apple's documentation for bundle ID's, it must contain only alphanumeric characters (A–Z, a–z, and 0–9), hyphens (-), and periods (.). However, an attacker can manually modify this value in the `Info.plist` file and add special characters to the `<key>CFBundleIdentifier</key>` value. The `dynamic_analysis.html` file does not sanitize the received bundle value from Corellium and as a result, it is possible to break the HTML context and achieve Stored XSS. This issue has been addressed in version 4.3.1 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-24803?

3 open source packages ship an affected version, including mobsf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mobsf` | PyPI | All versions | 4.3.1 |
| `mobsf` | PyPI | All versions | 4.3.1 |
| `mobsf` | PyPI | All versions | 4.3.1 |

Products: Opensecurity Mobile Security Framework.

## How do I fix CVE-2025-24803?

Upgrade mobsf to 4.3.1 or later.

## Is CVE-2025-24803 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24803 exists.

## Other vulnerabilities in Mobile-Security-Framework-MobSF

- [CVE-2025-46335](https://insights.sbomify.com/CVE-2025-46335/): Mobile Security Framework (MobSF) Allows Stored Cross Site Scripting (XSS) via malicious SVG Icon Upload (high 8.6)
- [CVE-2025-24805](https://insights.sbomify.com/CVE-2025-24805/): Local Privilege Escalation in MobSF (high 8.5)
- [CVE-2026-24490](https://insights.sbomify.com/CVE-2026-24490/): MobSF has Stored XSS via Manifest Analysis - Dialer Code Host Field (high 8.1)
- [CVE-2024-53999](https://insights.sbomify.com/CVE-2024-53999/): Mobile Security Framework (MobSF) Stored Cross-Site Scripting Vulnerability in "Diff or Compare" Functionality (high 8.1)
- [CVE-2024-43399](https://insights.sbomify.com/CVE-2024-43399/): Mobile Security Framework (MobSF) has a Zip Slip Vulnerability in .a Static Library Files (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24803 and fix it if it is affected.

What it is: CVE-2025-24803 is a high-severity cross-site scripting vulnerability in Mobile-Security-Framework-MobSF, published on 5 Feb 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24803 exists.

Affected packages and fixed versions:
- mobsf (PyPI): affected all versions; fixed in 4.3.1
- mobsf (PyPI): affected all versions; fixed in 4.3.1
- mobsf (PyPI): affected all versions; fixed in 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24803/ (Markdown: https://insights.sbomify.com/CVE-2025-24803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24803
- OSV: https://osv.dev/vulnerability/CVE-2025-24803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24803/
Summaries are generated and may contain mistakes; the official description above is the record.
