CVE-2025-24813 Apache Tomcat Path Equivalence
Attackers can exploit path equivalence in partial PUT requests to execute code or read sensitive files if default servlet writes are enabled.
- Exploited in the wild
- Since 1 Apr 2025
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-24813?
CVE-2025-24813 is a critical path traversal vulnerability in Apache Tomcat, published on 10 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT
If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack
Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.
Which versions are affected by CVE-2025-24813?
17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-catalina. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.35 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.35 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.3 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.3 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
11 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.99 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.99 |
tomcat Bitnami | All versions | 9.0.99, 10.1.35, 11.0.3 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.35 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.35 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.3 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.3 |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0.M1 | 9.0.99 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0.M1 | 9.0.99 |
Linux distribution packages (23)
tomcat9 AlmaLinux:10 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-admin-webapps AlmaLinux:10 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-docs-webapp AlmaLinux:10 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-el-3.0-api AlmaLinux:10 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-jsp-2.3-api AlmaLinux:10 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-lib AlmaLinux:10 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-servlet-4.0-api AlmaLinux:10 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-webapps AlmaLinux:10 | All versions | 1:9.0.87-5.el10_0 |
tomcat9 Red Hat:enterprise_linux:10.0 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-admin-webapps Red Hat:enterprise_linux:10.0 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-docs-webapp Red Hat:enterprise_linux:10.0 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-el-3.0-api Red Hat:enterprise_linux:10.0 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-jsp-2.3-api Red Hat:enterprise_linux:10.0 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-lib Red Hat:enterprise_linux:10.0 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-servlet-4.0-api Red Hat:enterprise_linux:10.0 | All versions | 1:9.0.87-5.el10_0 |
tomcat9-webapps Red Hat:enterprise_linux:10.0 | All versions | 1:9.0.87-5.el10_0 |
jws5-tomcat Red Hat:jboss_enterprise_web_server:5.8::el7 | All versions | 0:9.0.87-8.redhat_00008.1.el7jws |
jws5-tomcat-admin-webapps Red Hat:jboss_enterprise_web_server:5.8::el7 | All versions | 0:9.0.87-8.redhat_00008.1.el7jws |
jws5-tomcat-docs-webapp Red Hat:jboss_enterprise_web_server:5.8::el7 | All versions | 0:9.0.87-8.redhat_00008.1.el7jws |
jws5-tomcat-el-3.0-api Red Hat:jboss_enterprise_web_server:5.8::el7 | All versions | 0:9.0.87-8.redhat_00008.1.el7jws |
jws5-tomcat-java-jdk11 Red Hat:jboss_enterprise_web_server:5.8::el7 | All versions | 0:9.0.87-8.redhat_00008.1.el7jws |
jws5-tomcat-java-jdk8 Red Hat:jboss_enterprise_web_server:5.8::el7 | All versions | 0:9.0.87-8.redhat_00008.1.el7jws |
jws5-tomcat-javadoc Red Hat:jboss_enterprise_web_server:5.8::el7 | All versions | 0:9.0.87-8.redhat_00008.1.el7jws |
Products include Apache Tomcat, Debian Debian Linux, Netapp Bootstrap Os.
How do I fix CVE-2025-24813?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.35, 11.0.3 or 9.0.99. US federal agencies must fix it by 22 Apr 2025.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-24813 being exploited?
Yes. Attackers have exploited CVE-2025-24813 in the wild since at least 1 Apr 2025.
Public exploit code: 1 Metasploit module, 1 Exploit-DB entry, 1 Nuclei template and 60 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
- CVE-2016-8735 Apache Tomcat Remote Code Execution
- CVE-2017-12617 Apache Tomcat Remote Code Execution
- CVE-2017-12615 Apache Tomcat on Windows Remote Code Execution
- CVE-2026-34486 Apache Tomcat Missing Encryption of Sensitive Data
- CVE-2026-65637 Apache Tomcat: HTTP/2 no-authority bypass of strict SNI validation - CVE-2026-32990 fix incomplete
Sources
Also known as ALSA-2025:7494, BIT-tomcat-2025-24813, CLSA-2025-1742577759, CLSA-2025-1742733084, CLSA-2025-1742737069, CLSA-2025-1750752721 and 16 more.