CVE-2025-24814 Apache Solr: Core-creation with "trusted" configset can use arbitrary untrusted files

Medium 5.4 Published Updated

Attackers can load malicious code by replacing trusted config files in unauthenticated Solr instances using FileSystemConfigSetService.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-24814?

CVE-2025-24814 is a medium-severity vulnerability in Apache Solr, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Core creation allows users to replace "trusted" configset files with arbitrary configuration

Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem.  These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin.

This issue affects all Apache Solr versions up through Solr 9.7.  Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService").  Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.

Weakness: CWE-250

Which versions are affected by CVE-2025-24814?

3 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.

PackageAffectedFixed in
org.apache.solr:solr-core MavenAll versions9.8.0
org.apache.solr:solr-core MavenAll versions9.8.0
solr BitnamiAll versions9.8.0

Products include Apache Solr.

How do I fix CVE-2025-24814?

Upgrade org.apache.solr:solr-core to 9.8.0 or later.

Is CVE-2025-24814 being exploited?

There is no known exploitation of CVE-2025-24814 in the wild and no public exploit code.

Sources

Also known as BIT-solr-2025-24814, CLSA-2026-1793053857, DEBIAN-CVE-2025-24814, GHSA-68r2-fwcg-qpm8, UBUNTU-CVE-2025-24814.

Is CVE-2025-24814 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free