{"answers":{"affected":"3 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-24814 in the wild and no public exploit code.","fix":"Upgrade org.apache.solr:solr-core to 9.8.0 or later.","what":"CVE-2025-24814 is a medium-severity vulnerability in Apache Solr, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24814 and fix it if it is affected.\n\nWhat it is: CVE-2025-24814 is a medium-severity vulnerability in Apache Solr, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24814 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.solr:solr-core (Maven): affected all versions; fixed in 9.8.0\n- org.apache.solr:solr-core (Maven): affected all versions; fixed in 9.8.0\n- solr (Bitnami): affected all versions; fixed in 9.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24814/ (Markdown: https://insights.sbomify.com/CVE-2025-24814/index.md)","id":"CVE-2025-24814","markdown":"https://insights.sbomify.com/CVE-2025-24814/index.md","name":"CVE-2025-24814","record":{"aliases":["BIT-solr-2025-24814","CLSA-2026-1793053857","DEBIAN-CVE-2025-24814","GHSA-68r2-fwcg-qpm8","UBUNTU-CVE-2025-24814"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Solr search engine","requires_auth":"low_privilege","summary":"Attackers can load malicious code by replacing trusted config files in unauthenticated Solr instances using FileSystemConfigSetService.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"solr","vendor":"apache"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-250","name":"Execution with Unnecessary Privileges"}],"description":"Core creation allows users to replace \"trusted\" configset files with arbitrary configuration\n\nSolr instances that (1) use the \"FileSystemConfigSetService\" component (the default in \"standalone\" or \"user-managed\" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual \"trusted\" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem.  These replacement config files are treated as \"trusted\" and can use \"\u003clib\u003e\" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin.\n\nThis issue affects all Apache Solr versions up through Solr 9.7.  Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from \"FileSystemConfigSetService\").  Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of \"\u003clib\u003e\" tags by default.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Solr: Core-creation with \"trusted\" configset can use arbitrary untrusted files","id":"CVE-2025-24814","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"An unrestricted file upload vulnerability in Nokia MantaRay NM","id":"CVE-2025-24815"},"packages":[{"ecosystem":"Bitnami","fixed":["9.8.0"],"introduced":["0"],"last_affected":[],"package":"solr","purl":"pkg:bitnami/solr","source":"BIT-solr-2025-24814"},{"ecosystem":"Maven","fixed":["9.8.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.solr:solr-core","purl":null,"source":"GHSA-68r2-fwcg-qpm8"},{"ecosystem":"Maven","fixed":["9.8.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.solr:solr-core","purl":"pkg:maven/org.apache.solr/solr-core","source":"GHSA-68r2-fwcg-qpm8"}],"prev":{"headline":"Apache Tomcat Path Equivalence","id":"CVE-2025-24813"},"products":["Apache Solr"],"published":"2025-01-27","related":[{"cvss_score":7.5,"headline":"Apache Solr VelocityResponseWriter Plug-In Remote Code Execution","id":"CVE-2019-17558","kev_date_added":"2021-11-03","published":"2019-12-30"},{"cvss_score":7.2,"headline":"Apache Solr DataImportHandler Code Injection","id":"CVE-2019-0193","kev_date_added":"2021-12-10","published":"2019-08-01"},{"cvss_score":9.8,"headline":"Apache Solr: Authentication bypass possible using a fake URL Path ending","id":"CVE-2024-45216","kev_date_added":null,"published":"2024-10-16"},{"cvss_score":9.8,"headline":"Apache Solr information disclosure vulnerability through DataImportHandler","id":"CVE-2021-44548","kev_date_added":null,"published":"2021-12-23"},{"cvss_score":9.8,"headline":"SSRF vulnerability with the Replication handler","id":"CVE-2021-27905","kev_date_added":null,"published":"2021-04-13"},{"cvss_score":9.8,"headline":"Incorrect Authorization in Apache Solr","id":"CVE-2020-13957","kev_date_added":null,"published":"2020-10-13"},{"cvss_score":9.8,"headline":"Unrestricted upload of file with dangerous type in Apache Solr","id":"CVE-2019-12409","kev_date_added":null,"published":"2019-11-18"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-15","vendors":["Apache Software Foundation"]},"summary":"Attackers can load malicious code by replacing trusted config files in unauthenticated Solr instances using FileSystemConfigSetService.","url":"https://insights.sbomify.com/CVE-2025-24814/"}