# CVE-2025-24814: Apache Solr: Core-creation with "trusted" configset can use arbitrary untrusted files

> Attackers can load malicious code by replacing trusted config files in unauthenticated Solr instances using FileSystemConfigSetService.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2025
- **Updated:** 15 Feb 2025
- **Also known as:** BIT-solr-2025-24814, CLSA-2026-1793053857, DEBIAN-CVE-2025-24814, GHSA-68r2-fwcg-qpm8, UBUNTU-CVE-2025-24814

## What is CVE-2025-24814?

CVE-2025-24814 is a medium-severity vulnerability in Apache Solr, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Core creation allows users to replace "trusted" configset files with arbitrary configuration

Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem.  These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin.

This issue affects all Apache Solr versions up through Solr 9.7.  Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService").  Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.

Weakness: CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2025-24814?

3 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | All versions | 9.8.0 |
| `org.apache.solr:solr-core` | Maven | All versions | 9.8.0 |
| `solr` | Bitnami | All versions | 9.8.0 |

Products: Apache Solr.

## How do I fix CVE-2025-24814?

Upgrade org.apache.solr:solr-core to 9.8.0 or later.

## Is CVE-2025-24814 being exploited?

There is no known exploitation of CVE-2025-24814 in the wild and no public exploit code.

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24814 and fix it if it is affected.

What it is: CVE-2025-24814 is a medium-severity vulnerability in Apache Solr, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24814 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 9.8.0
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 9.8.0
- solr (Bitnami): affected all versions; fixed in 9.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24814/ (Markdown: https://insights.sbomify.com/CVE-2025-24814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24814
- OSV: https://osv.dev/vulnerability/CVE-2025-24814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24814/
Summaries are generated and may contain mistakes; the official description above is the record.
