CVE-2025-24839 Unauthorized AI bot activation via Wrangler plugin
Unauthorized users can trigger AI bot responses by exploiting a missing authorization check in the Wrangler plugin when AI features are enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-24839?
CVE-2025-24839 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to prevent Wrangler posts from triggering AI responses. This vulnerability allows users without access to the AI bot to activate it by attaching the activate_ai override property to a post via the Wrangler plugin, provided both the AI and Wrangler plugins are enabled.
Weakness: CWE-863
Which versions are affected by CVE-2025-24839?
12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250218121836-2b5275d87136 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250314142426-c049748b8863 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250314142426-c049748b8863 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0 | 10.4.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0 | 10.4.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.2 |
6 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.10 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.10 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.10+incompatible, 10.4.4+incompatible, 10.5.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-24839?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250218121836-2b5275d87136, 8.0.0-20250314142426-c049748b8863, 10.4.4 or 10.5.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-24839 being exploited?
There is no known exploitation of CVE-2025-24839 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-j639-m367-75cf, GO-2025-3621.