# CVE-2025-2485: Deserialization in Drag and Drop Multiple File Upload for Contact Form 7

> Unauthenticated attackers can inject PHP objects via PHAR files in a WordPress plugin, potentially leading to arbitrary file deletion or code execution if a POP chain exists.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Mar 2025
- **Updated:** 8 Apr 2026
- **Also known as:** BELL-CVE-2025-2485, GHSA-qv6w-444m-m6w6

## What is CVE-2025-2485?

CVE-2025-2485 is a high-severity unsafe deserialization vulnerability in glenwpcoder Drag and Drop Multiple File Upload for Contact Form 7, published on 28 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Drag and Drop Multiple File Upload for Contact Form 7 plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.3.8.7 via deserialization of untrusted input from the 'dnd_upload_cf7_upload'
 function. This makes it possible for attackers to inject a PHP Object through a PHAR file. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present. This vulnerability may be exploited by unauthenticated attackers when a form is present on the site with the file upload action. The Flamingo plugin must be installed and activated in order to exploit the vulnerability. The vulnerability was partially patched in version 1.3.8.8.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-2485?

It affects 1 product.


Products: Codedropz Drag and Drop Multiple File Upload - Contact Form 7.

## How do I fix CVE-2025-2485?

Apply the vendor's patch.

## Is CVE-2025-2485 being exploited?

There is no known exploitation of CVE-2025-2485 in the wild and no public exploit code.

## Other vulnerabilities in glenwpcoder Drag and Drop Multiple File Upload for Contact Form 7

- [CVE-2020-12800](https://insights.sbomify.com/CVE-2020-12800/): File upload in n/a (critical 9.8)
- [CVE-2025-2328](https://insights.sbomify.com/CVE-2025-2328/): Drag and Drop Multiple File Upload for Contact Form 7 <= 1.3.8.7 - Unauthenticated Arbitrary File Deletion (high 8.8)
- [CVE-2025-3515](https://insights.sbomify.com/CVE-2025-3515/): File upload in Drag and Drop Multiple File Upload for Contact Form 7 (high 8.1)
- [CVE-2023-5822](https://insights.sbomify.com/CVE-2023-5822/): Drag and Drop Multiple File Upload - Contact Form 7 <= 1.3.7.3 - Unauthenticated Arbitrary File Upload (high 8.1)
- [CVE-2023-1282](https://insights.sbomify.com/CVE-2023-1282/): Drag and Drop Multiple File Upload PRO - Reflected Cross-Site Scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-2485 and fix it if it is affected.

What it is: CVE-2025-2485 is a high-severity unsafe deserialization vulnerability in glenwpcoder Drag and Drop Multiple File Upload for Contact Form 7, published on 28 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-2485 in the wild and no public exploit code.

Affected product: glenwpcoder Drag and Drop Multiple File Upload for Contact Form 7. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-2485/ (Markdown: https://insights.sbomify.com/CVE-2025-2485/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-2485
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-2485
- OSV: https://osv.dev/vulnerability/CVE-2025-2485

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-2485/
Summaries are generated and may contain mistakes; the official description above is the record.
