CVE-2025-24855 Use after free in libxslt
A use-after-free in libxslt allows attackers to execute arbitrary code or cause denial of service via nested XPath evaluations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-24855?
CVE-2025-24855 is a high-severity use after free vulnerability in xmlsoft libxslt, published on 14 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
numbers.c in libxslt before 1.1.43 has a use-after-free because, in nested XPath evaluations, an XPath context node can be modified but never restored. This is related to xsltNumberFormatGetValue, xsltEvalXPathPredicate, xsltEvalXPathStringNs, and xsltComputeSortResultInternal.
Weakness: CWE-416
Which versions are affected by CVE-2025-24855?
3 open source packages ship an affected version, including java, java-min and jre. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | All versions | 1.8.0, 8.0.461 |
java-min Bitnami | All versions | 1.8.0, 8.0.461 |
jre Bitnami | All versions | 1.8.0, 8.0.461 |
Linux distribution packages (14)
libxslt AlmaLinux:9 | All versions | 1.1.34-9.el9_5.1 |
libxslt-devel AlmaLinux:9 | All versions | 1.1.34-9.el9_5.1 |
libxslt Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.34-9.el9_5.1 |
libxslt-debuginfo Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.34-9.el9_5.1 |
libxslt-debugsource Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.34-9.el9_5.1 |
libxslt-devel Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.34-9.el9_5.1 |
libxslt Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.1.34-10.el9_2 |
libxslt-debuginfo Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.1.34-10.el9_2 |
libxslt-debugsource Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.1.34-10.el9_2 |
libxslt-devel Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.1.34-10.el9_2 |
libxslt Red Hat:rhel_eus:9.4::appstream | All versions | 0:1.1.34-10.el9_4 |
libxslt-debuginfo Red Hat:rhel_eus:9.4::appstream | All versions | 0:1.1.34-10.el9_4 |
libxslt-debugsource Red Hat:rhel_eus:9.4::appstream | All versions | 0:1.1.34-10.el9_4 |
libxslt-devel Red Hat:rhel_eus:9.4::appstream | All versions | 0:1.1.34-10.el9_4 |
Products include Xmlsoft Libxslt.
How do I fix CVE-2025-24855?
Upgrade java to a fixed version for your release line: 1.8.0 or 8.0.461.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2025-24855 being exploited?
There is no known exploitation of CVE-2025-24855 in the wild and no public exploit code.
Other vulnerabilities in xmlsoft libxslt
Sources
Also known as ALPINE-CVE-2025-24855, ALSA-2025:3107, AZL-58644, AZL-58665, BELL-CVE-2025-24855, BIT-java-2025-24855 and 15 more.