CVE-2025-24859 Apache Roller: Insufficient Session Expiration on Password Change

Low 2.1 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2025-24859?

CVE-2025-24859 is a low-severity vulnerability in Apache Roller, published on 14 Apr 2025.

Official description

A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes. When a user's password is changed, either by the user themselves or by an administrator, existing sessions remain active and usable. This allows continued access to the application through old sessions even after password changes, potentially enabling unauthorized access if credentials were compromised.

This issue affects Apache Roller versions up to and including 6.1.4.

The vulnerability is fixed in Apache Roller 6.1.5 by implementing centralized session management that properly invalidates all active sessions when passwords are changed or users are disabled.

Weakness: CWE-613

Which versions are affected by CVE-2025-24859?

It affects 1 product.

Products include Apache Roller.

How do I fix CVE-2025-24859?

No fix has been published for CVE-2025-24859 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-24859 being exploited?

There is no known exploitation of CVE-2025-24859 in the wild and no public exploit code.

Sources

Also known as GHSA-fqfw-5jc9-hw27.

Is CVE-2025-24859 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free