{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-24859 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-24859 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-24859 is a low-severity vulnerability in Apache Roller, published on 14 Apr 2025."},"fix_prompt":"Check this codebase for CVE-2025-24859 and fix it if it is affected.\n\nWhat it is: CVE-2025-24859 is a low-severity vulnerability in Apache Roller, published on 14 Apr 2025. \nExploitation: There is no known exploitation of CVE-2025-24859 in the wild and no public exploit code.\n\nAffected product: Apache Roller. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24859/ (Markdown: https://insights.sbomify.com/CVE-2025-24859/index.md)","id":"CVE-2025-24859","markdown":"https://insights.sbomify.com/CVE-2025-24859/index.md","name":"CVE-2025-24859","record":{"aliases":["GHSA-fqfw-5jc9-hw27"],"analysis":null,"analysis_generated_by":null,"assigner":"apache","cpe":[{"product":"roller","vendor":"apache"}],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/S:N/AU:N/R:U/RE:L/U:Amber","version":"4.0"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes. When a user's password is changed, either by the user themselves or by an administrator, existing sessions remain active and usable. This allows continued access to the application through old sessions even after password changes, potentially enabling unauthorized access if credentials were compromised.\n\nThis issue affects Apache Roller versions up to and including 6.1.4.\n\nThe vulnerability is fixed in Apache Roller 6.1.5 by implementing centralized session management that properly invalidates all active sessions when passwords are changed or users are disabled.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache Roller: Insufficient Session Expiration on Password Change","id":"CVE-2025-24859","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Apache Cassandra: CassandraNetworkAuthorizer and CassandraCIDRAuthorizer can be bypassed allowing access to different network regions","id":"CVE-2025-24860"},"packages":[],"prev":{"headline":"Information disclosure in Enterprise","id":"CVE-2025-24858"},"products":["Apache Roller"],"published":"2025-04-14","related":[{"cvss_score":9.8,"headline":"Server-side request forgery in Apache Roller","id":"CVE-2018-17198","kev_date_added":null,"published":"2019-05-28"},{"cvss_score":9.8,"headline":"XML external entity in n/a","id":"CVE-2014-0030","kev_date_added":null,"published":"2017-10-09"},{"cvss_score":7.5,"headline":"regex injection leading to DoS","id":"CVE-2021-33580","kev_date_added":null,"published":"2021-08-18"},{"cvss_score":7.2,"headline":"Code injection in n/a","id":"CVE-2015-0249","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":6.8,"headline":"Code injection in n/a","id":"CVE-2013-4212","kev_date_added":null,"published":"2013-12-07"},{"cvss_score":6.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2012-2380","kev_date_added":null,"published":"2012-06-26"},{"cvss_score":6.1,"headline":"Cross-site scripting in Apache Roller","id":"CVE-2019-0234","kev_date_added":null,"published":"2019-07-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["Apache Software Foundation"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2025-24859/"}