# CVE-2025-24859: Apache Roller: Insufficient Session Expiration on Password Change


- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/S:N/AU:N/R:U/RE:L/U:Amber`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 14 Apr 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-fqfw-5jc9-hw27

## What is CVE-2025-24859?

CVE-2025-24859 is a low-severity vulnerability in Apache Roller, published on 14 Apr 2025. 

### Official description

A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes. When a user's password is changed, either by the user themselves or by an administrator, existing sessions remain active and usable. This allows continued access to the application through old sessions even after password changes, potentially enabling unauthorized access if credentials were compromised.

This issue affects Apache Roller versions up to and including 6.1.4.

The vulnerability is fixed in Apache Roller 6.1.5 by implementing centralized session management that properly invalidates all active sessions when passwords are changed or users are disabled.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-24859?

It affects 1 product.


Products: Apache Roller.

## How do I fix CVE-2025-24859?

No fix has been published for CVE-2025-24859 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-24859 being exploited?

There is no known exploitation of CVE-2025-24859 in the wild and no public exploit code.

## Other vulnerabilities in Apache Roller

- [CVE-2018-17198](https://insights.sbomify.com/CVE-2018-17198/): Server-side request forgery in Apache Roller (critical 9.8)
- [CVE-2014-0030](https://insights.sbomify.com/CVE-2014-0030/): XML external entity in n/a (critical 9.8)
- [CVE-2021-33580](https://insights.sbomify.com/CVE-2021-33580/): regex injection leading to DoS (high 7.5)
- [CVE-2015-0249](https://insights.sbomify.com/CVE-2015-0249/): Code injection in n/a (high 7.2)
- [CVE-2013-4212](https://insights.sbomify.com/CVE-2013-4212/): Code injection in n/a (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24859 and fix it if it is affected.

What it is: CVE-2025-24859 is a low-severity vulnerability in Apache Roller, published on 14 Apr 2025. 
Exploitation: There is no known exploitation of CVE-2025-24859 in the wild and no public exploit code.

Affected product: Apache Roller. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24859/ (Markdown: https://insights.sbomify.com/CVE-2025-24859/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24859
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24859
- OSV: https://osv.dev/vulnerability/CVE-2025-24859

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24859/
Summaries are generated and may contain mistakes; the official description above is the record.
