CVE-2025-24860 Apache Cassandra: CassandraNetworkAuthorizer and CassandraCIDRAuthorizer can be bypassed allowing access to different network regions
Users with restricted network access can bypass authorization controls to modify their own permissions and access unauthorized data centers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-24860?
CVE-2025-24860 is a medium-severity missing authorization vulnerability in Apache Cassandra, published on 4 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer.
Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions.
This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer.
Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
Weakness: CWE-863
Which versions are affected by CVE-2025-24860?
7 open source packages ship an affected version, including org.apache.cassandra:cassandra-all and cassandra. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.cassandra:cassandra-all Maven | From 4.0-alpha1 | 4.0.16 |
org.apache.cassandra:cassandra-all Maven | From 4.0-alpha1 | 4.0.16 |
org.apache.cassandra:cassandra-all Maven | From 4.1-alpha1 | 4.1.8 |
org.apache.cassandra:cassandra-all Maven | From 4.1-alpha1 | 4.1.8 |
org.apache.cassandra:cassandra-all Maven | From 5.0-alpha1 | 5.0.3 |
org.apache.cassandra:cassandra-all Maven | From 5.0-alpha1 | 5.0.3 |
1 more packages
cassandra Bitnami | From 4.0.0 | 4.0.16, 4.1.8, 5.0.3 |
Products include Apache Cassandra.
How do I fix CVE-2025-24860?
Upgrade org.apache.cassandra:cassandra-all to a fixed version for your release line: 4.0.16, 4.1.8 or 5.0.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-24860 being exploited?
There is no known exploitation of CVE-2025-24860 in the wild and no public exploit code.
Other vulnerabilities in Apache Cassandra
- CVE-2016-3427 Oracle Java SE and JRockit Unspecified
- CVE-2018-8016 Missing Authentication for Critical Function in Apache Cassandra
- CVE-2021-44521 Remote code execution for scripted UDFs
- CVE-2026-27314 Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass
- CVE-2025-26467 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)
Sources
Also known as AZL-56433, AZL-56440, BIT-cassandra-2025-24860, CLEANSTART-2026-VT42606, GHSA-3cjf-fwcq-xh22, MINI-chvf-v3fj-rcr6 and 2 more.