# CVE-2025-24860: Apache Cassandra: CassandraNetworkAuthorizer and CassandraCIDRAuthorizer can be bypassed allowing access to different network regions

> Users with restricted network access can bypass authorization controls to modify their own permissions and access unauthorized data centers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2025
- **Updated:** 15 Feb 2025
- **Also known as:** AZL-56433, AZL-56440, BIT-cassandra-2025-24860, CLEANSTART-2026-VT42606, GHSA-3cjf-fwcq-xh22, MINI-chvf-v3fj-rcr6, MINI-gwhm-jv9g-4rfw, MINI-p3rq-24hh-8mcx

## What is CVE-2025-24860?

CVE-2025-24860 is a medium-severity missing authorization vulnerability in Apache Cassandra, published on 4 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer.

Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions.

This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer.

Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-24860?

7 open source packages ship an affected version, including org.apache.cassandra:cassandra-all and cassandra. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.0-alpha1 | 4.0.16 |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.0-alpha1 | 4.0.16 |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.1-alpha1 | 4.1.8 |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.1-alpha1 | 4.1.8 |
| `org.apache.cassandra:cassandra-all` | Maven | From 5.0-alpha1 | 5.0.3 |
| `org.apache.cassandra:cassandra-all` | Maven | From 5.0-alpha1 | 5.0.3 |
| `cassandra` | Bitnami | From 4.0.0 | 4.0.16, 4.1.8, 5.0.3 |

Products: Apache Cassandra.

## How do I fix CVE-2025-24860?

Upgrade org.apache.cassandra:cassandra-all to a fixed version for your release line: 4.0.16, 4.1.8 or 5.0.3.

## Is CVE-2025-24860 being exploited?

There is no known exploitation of CVE-2025-24860 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cassandra

- [CVE-2016-3427](https://insights.sbomify.com/CVE-2016-3427/): Oracle Java SE and JRockit Unspecified (critical 9.8, exploited in the wild)
- [CVE-2018-8016](https://insights.sbomify.com/CVE-2018-8016/): Missing Authentication for Critical Function in Apache Cassandra (critical 9.8)
- [CVE-2021-44521](https://insights.sbomify.com/CVE-2021-44521/): Remote code execution for scripted UDFs (critical 9.1)
- [CVE-2026-27314](https://insights.sbomify.com/CVE-2026-27314/): Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass (high 8.8)
- [CVE-2025-26467](https://insights.sbomify.com/CVE-2025-26467/): Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24860 and fix it if it is affected.

What it is: CVE-2025-24860 is a medium-severity missing authorization vulnerability in Apache Cassandra, published on 4 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24860 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cassandra:cassandra-all (Maven): affected from 4.0-alpha1; fixed in 4.0.16
- org.apache.cassandra:cassandra-all (Maven): affected from 4.0-alpha1; fixed in 4.0.16
- org.apache.cassandra:cassandra-all (Maven): affected from 4.1-alpha1; fixed in 4.1.8
- org.apache.cassandra:cassandra-all (Maven): affected from 4.1-alpha1; fixed in 4.1.8
- org.apache.cassandra:cassandra-all (Maven): affected from 5.0-alpha1; fixed in 5.0.3
- org.apache.cassandra:cassandra-all (Maven): affected from 5.0-alpha1; fixed in 5.0.3
- cassandra (Bitnami): affected from 4.0.0; fixed in 4.0.16, 4.1.8, 5.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24860/ (Markdown: https://insights.sbomify.com/CVE-2025-24860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24860
- OSV: https://osv.dev/vulnerability/CVE-2025-24860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24860/
Summaries are generated and may contain mistakes; the official description above is the record.
