CVE-2025-24866 Unauthorized Access to User Activity Logs API by delegated granular administration roles
Attackers with delegated admin roles can access user activity logs without proper authorization, exposing sensitive compliance data.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-24866?
CVE-2025-24866 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 10 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 9.11.x <= 9.11.8 fail to enforce proper access controls on the /api/v4/audits endpoint, allowing users with delegated granular administration roles who lack access to Compliance Monitoring to retrieve User Activity Logs.
Weakness: CWE-863
Which versions are affected by CVE-2025-24866?
8 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250204211032-f52e08754c49 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250204211032-f52e08754c49 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.9 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.9 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.9+incompatible |
2 more packages
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-24866?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250204211032-f52e08754c49 or 9.11.9.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-24866 being exploited?
There is no known exploitation of CVE-2025-24866 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-xfq9-hh5x-xfq9, GO-2025-3604.