# CVE-2025-24883: go-ethereum has a DoS via malicious p2p message

> A malicious peer-to-peer message can crash a go-ethereum node, causing a denial of service for Ethereum network participants.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2025
- **Updated:** 30 Jan 2025
- **Also known as:** GHSA-q26p-9cq4-7fc2, GO-2025-3436

## What is CVE-2025-24883?

CVE-2025-24883 is a high-severity denial of service vulnerability in go-ethereum, published on 30 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

go-ethereum (geth) is a golang execution layer implementation of the Ethereum protocol. A vulnerable node can be forced to shutdown/crash using a specially crafted message. This vulnerability is fixed in 1.14.13.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-24883?

3 open source packages ship an affected version, including github.com/ethereum/go-ethereum.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ethereum/go-ethereum` | Go | From 1.14.0 | 1.14.13 |
| `github.com/ethereum/go-ethereum` | Go | From 1.14.0 | 1.14.13 |
| `github.com/ethereum/go-ethereum` | Go | From 1.14.0 | 1.14.13 |

## How do I fix CVE-2025-24883?

Upgrade github.com/ethereum/go-ethereum to 1.14.13 or later.

## Is CVE-2025-24883 being exploited?

There is no known exploitation of CVE-2025-24883 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24883 and fix it if it is affected.

What it is: CVE-2025-24883 is a high-severity denial of service vulnerability in go-ethereum, published on 30 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24883 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ethereum/go-ethereum (Go): affected from 1.14.0; fixed in 1.14.13
- github.com/ethereum/go-ethereum (Go): affected from 1.14.0; fixed in 1.14.13
- github.com/ethereum/go-ethereum (Go): affected from 1.14.0; fixed in 1.14.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24883/ (Markdown: https://insights.sbomify.com/CVE-2025-24883/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24883
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24883
- OSV: https://osv.dev/vulnerability/CVE-2025-24883

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24883/
Summaries are generated and may contain mistakes; the official description above is the record.
