{"answers":{"affected":"1 open source package ship an affected version, including pycti. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-24887 in the wild and no public exploit code.","fix":"Upgrade pycti to 6.4.11 or later.","what":"CVE-2025-24887 is a medium-severity missing authorization vulnerability in OpenCTI-Platform opencti, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24887 and fix it if it is affected.\n\nWhat it is: CVE-2025-24887 is a medium-severity missing authorization vulnerability in OpenCTI-Platform opencti, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24887 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pycti (PyPI): affected from 6.4.9; fixed in 6.4.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24887/ (Markdown: https://insights.sbomify.com/CVE-2025-24887/index.md)","id":"CVE-2025-24887","markdown":"https://insights.sbomify.com/CVE-2025-24887/index.md","name":"CVE-2025-24887","record":{"aliases":["GHSA-8262-pw2q-5qc3","PYSEC-2025-178"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCTI threat intelligence","requires_auth":"low_privilege","summary":"Attackers can bypass attribute restrictions to modify protected user fields and enumerate accounts in OpenCTI.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opencti","vendor":"citeum"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-657","name":"Violation of Secure Design Principles"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"OpenCTI is an open-source cyber threat intelligence platform. In versions starting from 6.4.8 to before 6.4.10, the allow/deny lists can be bypassed, allowing a user to change attributes that are intended to be unmodifiable by the user. It is possible to toggle the `external` flag on/off and change the own token value for a user. It is also possible to edit attributes that are not in the allow list, such as `otp_qr` and `otp_activated`. If external users exist in the OpenCTI setup and the information about these users identities is sensitive, the above vulnerabilities can be used to enumerate existing user accounts as a standard low privileged user. This issue has been patched in version 6.4.10.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenCTI bypass of protected attribute update","id":"CVE-2025-24887","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Path traversal in SecureDrop Client API.download_reply()","id":"CVE-2025-24888"},"packages":[{"ecosystem":"PyPI","fixed":["6.4.11"],"introduced":["6.4.9"],"last_affected":[],"package":"pycti","purl":"pkg:pypi/pycti","source":"PYSEC-2025-178"}],"prev":{"headline":"pwn.college has Symlink LFI in Dojo repos","id":"CVE-2025-24886"},"products":["opencti"],"published":"2025-04-30","related":[{"cvss_score":9.8,"headline":"OpenCTI privilege escalation and unauthenticated access via default admin account","id":"CVE-2026-27960","kev_date_added":null,"published":"2026-05-05"},{"cvss_score":9.1,"headline":"OpenCTI affected by RCE via notifier template","id":"CVE-2026-39980","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":9.1,"headline":"OpenCTI has remote code execution and sensitive secrets exposed through web hook","id":"CVE-2025-24977","kev_date_added":null,"published":"2025-05-05"},{"cvss_score":8.3,"headline":"OpenCTI Authenticated Privilege Escalation","id":"CVE-2024-26139","kev_date_added":null,"published":"2024-05-23"},{"cvss_score":8.1,"headline":"OpenCTI's lack of Rate Limit lead to OTP brute forcing","id":"CVE-2024-45404","kev_date_added":null,"published":"2024-12-11"},{"cvss_score":7.7,"headline":"OpenCTI has a Semi-Blind SSRF via Unvalidated External URL in Data Ingestion Feature","id":"CVE-2026-21887","kev_date_added":null,"published":"2026-03-12"},{"cvss_score":7.6,"headline":"OpenCTI vulnerable to Denial of Service through web hook","id":"CVE-2025-26621","kev_date_added":null,"published":"2025-05-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["OpenCTI-Platform"]},"summary":"Attackers can bypass attribute restrictions to modify protected user fields and enumerate accounts in OpenCTI.","url":"https://insights.sbomify.com/CVE-2025-24887/"}