# CVE-2025-24887: OpenCTI bypass of protected attribute update

> Attackers can bypass attribute restrictions to modify protected user fields and enumerate accounts in OpenCTI.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-8262-pw2q-5qc3, PYSEC-2025-178

## What is CVE-2025-24887?

CVE-2025-24887 is a medium-severity missing authorization vulnerability in OpenCTI-Platform opencti, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenCTI is an open-source cyber threat intelligence platform. In versions starting from 6.4.8 to before 6.4.10, the allow/deny lists can be bypassed, allowing a user to change attributes that are intended to be unmodifiable by the user. It is possible to toggle the `external` flag on/off and change the own token value for a user. It is also possible to edit attributes that are not in the allow list, such as `otp_qr` and `otp_activated`. If external users exist in the OpenCTI setup and the information about these users identities is sensitive, the above vulnerabilities can be used to enumerate existing user accounts as a standard low privileged user. This issue has been patched in version 6.4.10.

Weakness: CWE-657 (Violation of Secure Design Principles), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-24887?

1 open source package ship an affected version, including pycti. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pycti` | PyPI | From 6.4.9 | 6.4.11 |

Products: Citeum Opencti.

## How do I fix CVE-2025-24887?

Upgrade pycti to 6.4.11 or later.

## Is CVE-2025-24887 being exploited?

There is no known exploitation of CVE-2025-24887 in the wild and no public exploit code.

## Other vulnerabilities in OpenCTI-Platform opencti

- [CVE-2026-27960](https://insights.sbomify.com/CVE-2026-27960/): OpenCTI privilege escalation and unauthenticated access via default admin account (critical 9.8)
- [CVE-2026-39980](https://insights.sbomify.com/CVE-2026-39980/): OpenCTI affected by RCE via notifier template (critical 9.1)
- [CVE-2025-24977](https://insights.sbomify.com/CVE-2025-24977/): OpenCTI has remote code execution and sensitive secrets exposed through web hook (critical 9.1)
- [CVE-2024-26139](https://insights.sbomify.com/CVE-2024-26139/): OpenCTI Authenticated Privilege Escalation (high 8.3)
- [CVE-2024-45404](https://insights.sbomify.com/CVE-2024-45404/): OpenCTI's lack of Rate Limit lead to OTP brute forcing (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24887 and fix it if it is affected.

What it is: CVE-2025-24887 is a medium-severity missing authorization vulnerability in OpenCTI-Platform opencti, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24887 in the wild and no public exploit code.

Affected packages and fixed versions:
- pycti (PyPI): affected from 6.4.9; fixed in 6.4.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24887/ (Markdown: https://insights.sbomify.com/CVE-2025-24887/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24887
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24887
- OSV: https://osv.dev/vulnerability/CVE-2025-24887

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24887/
Summaries are generated and may contain mistakes; the official description above is the record.
