# CVE-2025-24890: gix-sec safe.directory protections absent for elevated administrators

> An administrator running gitoxide on Windows may execute malicious hooks from untrusted repositories, leading to privilege escalation.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** AZL-100953, AZL-100956, GHSA-7rhf-42qf-vrvc, MINI-m3hc-qxh8-qr2x

## What is CVE-2025-24890?

CVE-2025-24890 is a medium-severity vulnerability in GitoxideLabs gitoxide, published on 14 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

gitoxide is an implementation of git written in Rust. Prior to 0.13.3, the gix-sec crate on Windows incorrectly treats repositories controlled by another user as trusted when an administrator runs a dependent program with an unfiltered elevated token. In gix-sec/src/identity.rs, gix_sec::identity::is_path_owned_by_current_user obtains folder_owner and token_owner, but its administrator-specific IsWellKnownSid and CheckTokenMembership checks examine the running token rather than confirming the directory owner. This bypasses safe.directory-style protection for repositories owned and configured by a limited user, allowing repository configuration or hooks to execute commands with the administrator's privileges when an affected operation is performed. Exploitation requires Windows, an elevated administrator, a program that relies on gix-sec trust results, and interaction with a repository controlled by another user. An unelevated UAC process is not affected, and cloning is not affected because repository configuration and hooks are not copied. This issue is fixed in version 0.13.3.

Weakness: CWE-283 (Unverified Ownership)

## Which versions are affected by CVE-2025-24890?

2 open source packages ship an affected version, including gix-sec.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gix-sec` | crates.io | All versions | 0.13.3 |
| `gix-sec` | crates.io | All versions | 0.13.3 |

## How do I fix CVE-2025-24890?

Upgrade gix-sec to 0.13.3 or later.

## Is CVE-2025-24890 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24890 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24890 and fix it if it is affected.

What it is: CVE-2025-24890 is a medium-severity vulnerability in GitoxideLabs gitoxide, published on 14 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24890 exists.

Affected packages and fixed versions:
- gix-sec (crates.io): affected all versions; fixed in 0.13.3
- gix-sec (crates.io): affected all versions; fixed in 0.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24890/ (Markdown: https://insights.sbomify.com/CVE-2025-24890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24890
- OSV: https://osv.dev/vulnerability/CVE-2025-24890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24890/
Summaries are generated and may contain mistakes; the official description above is the record.
