# CVE-2025-24893: XWiki Platform Eval Injection

> Unauthenticated attackers can execute arbitrary Groovy code via SolrSearch requests, compromising the entire XWiki installation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 30 Oct 2025 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-rr6p-3pfg-562j

## What is CVE-2025-24893?

CVE-2025-24893 is a critical code injection vulnerability in Xwiki Xwiki, published on 20 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any guest can perform arbitrary remote code execution through a request to `SolrSearch`. This impacts the confidentiality, integrity and availability of the whole XWiki installation. To reproduce on an instance, without being logged in, go to `<host>/xwiki/bin/get/Main/SolrSearch?media=rss&text=%7D%7D%7D%7B%7Basync%20async%3Dfalse%7D%7D%7B%7Bgroovy%7D%7Dprintln%28"Hello%20from"%20%2B%20"%20search%20text%3A"%20%2B%20%2823%20%2B%2019%29%29%7B%7B%2Fgroovy%7D%7D%7B%7B%2Fasync%7D%7D%20`. If there is an output, and the title of the RSS feed contains `Hello from search text:42`, then the instance is vulnerable. This vulnerability has been patched in XWiki 15.10.11, 16.4.1 and 16.5.0RC1. Users are advised to upgrade. Users unable to upgrade may edit `Main.SolrSearchMacros` in `SolrSearchMacros.xml` on line 955 to match the `rawResponse` macro in `macros.vm#L2824` with a content type of `application/xml`, instead of simply outputting the content of the feed.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2025-24893?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-search-solr-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-search-solr-ui` | Maven | From 16.0.0-rc-1 | 16.4.1 |
| `org.xwiki.platform:xwiki-platform-search-solr-ui` | Maven | From 16.0.0-rc-1 | 16.4.1 |
| `org.xwiki.platform:xwiki-platform-search-solr-ui` | Maven | From 5.3-milestone-2 | 15.10.11 |
| `org.xwiki.platform:xwiki-platform-search-solr-ui` | Maven | From 5.3-milestone-2 | 15.10.11 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-24893?

Upgrade org.xwiki.platform:xwiki-platform-search-solr-ui to a fixed version for your release line: 16.4.1 or 15.10.11. US federal agencies must fix it by 20 Nov 2025.

## Is CVE-2025-24893 being exploited?

Yes. Attackers have exploited CVE-2025-24893 in the wild since at least 30 Oct 2025.

Public exploit code:

- PoC for CVE-2025-24893: XWiki' Remote Code Execution exploit for versions prior to 15.10.11, 16.4.1 and 16.5.0RC1. (github_poc): https://github.com/gunzf0x/CVE-2025-24893
- CVE-2025-24893 is a critical unauthenticated remote code execution vulnerability in XWiki (versions < 15.10.11, 16.4.1, 16.5.0RC1) caused by improper handling of Groovy expressions in the SolrSearch macro. (github_poc): https://github.com/dollarboysushil/CVE-2025-24893-XWiki-Unauthenticated-RCE-Exploit-POC
- https://github.com/b0ySie7e/CVE-2025-24893 (github_poc): https://github.com/b0ySie7e/CVE-2025-24893
- XWiki SolrSearchMacros 远程代码执行漏洞PoC（CVE-2025-24893） (github_poc): https://github.com/iSee857/CVE-2025-24893-PoC
- PoC exploits CVE-2025-24893 , a remote code execution (RCE) vulnerability in XWiki caused by improper sandboxing in Groovy macros rendered asynchronously. It allows arbitrary command execution through injection into RSS-based SolrSearch endpoints. (github_poc): https://github.com/Infinit3i/CVE-2025-24893
- This vulnerability could allow a malicious user to execute remote code by sending appropriately crafted requests to the default search engine SolrSearch (github_poc): https://github.com/Hex00-0x4/CVE-2025-24893-XWiki-RCE

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)
- [CVE-2024-38369](https://insights.sbomify.com/CVE-2024-38369/): XWiki programming rights may be inherited by inclusion (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24893 and fix it if it is affected.

What it is: CVE-2025-24893 is a critical code injection vulnerability in Xwiki Xwiki, published on 20 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2025-24893 in the wild since at least 30 Oct 2025.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-search-solr-ui (Maven): affected from 16.0.0-rc-1; fixed in 16.4.1
- org.xwiki.platform:xwiki-platform-search-solr-ui (Maven): affected from 16.0.0-rc-1; fixed in 16.4.1
- org.xwiki.platform:xwiki-platform-search-solr-ui (Maven): affected from 5.3-milestone-2; fixed in 15.10.11
- org.xwiki.platform:xwiki-platform-search-solr-ui (Maven): affected from 5.3-milestone-2; fixed in 15.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24893/ (Markdown: https://insights.sbomify.com/CVE-2025-24893/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24893
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24893
- OSV: https://osv.dev/vulnerability/CVE-2025-24893

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24893/
Summaries are generated and may contain mistakes; the official description above is the record.
