CVE-2025-24920 Unauthorized Bookmark Creation and Modification in Archived Channels

Medium 4.3 Published Updated

Authenticated users can create or modify bookmarks in archived channels due to missing authorization checks, allowing unauthorized data modification.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-24920?

CVE-2025-24920 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 21 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8, 10.5.x <= 10.5.0 fail to restrict bookmark creation and updates in archived channels, which allows authenticated users created or update bookmarked in archived channels

Weakness: CWE-863

Which versions are affected by CVE-2025-24920?

13 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoFrom 10.3.010.3.4
github.com/mattermost/mattermost/server/v8 GoFrom 10.3.010.3.4
github.com/mattermost/mattermost/server/v8 GoFrom 10.4.010.4.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.4.010.4.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.1
7 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.1
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.9
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.9
mattermost BitnamiFrom 9.11.010.0.0, 10.5.1
github.com/mattermost/mattermost-server GoFrom 9.11.0+incompatible9.11.9+incompatible, 10.3.4+incompatible, 10.4.3+incompatible, 10.5.1+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-24920?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 10.3.4, 10.4.3, 10.5.1 or 9.11.9.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-24920 being exploited?

There is no known exploitation of CVE-2025-24920 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as BIT-mattermost-2025-24920, GHSA-rp74-x43m-cpw3, GO-2025-3552.

Is CVE-2025-24920 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free