{"answers":{"affected":"3 open source packages ship an affected version, including java, java-min and jre. It affects 11 products.","exploited":"There is no known exploitation of CVE-2025-24928 in the wild and no public exploit code.","fix":"Upgrade java to a fixed version for your release line: 1.8.0 or 8.0.461.","what":"CVE-2025-24928 is a high-severity memory corruption vulnerability in Netapp Active Iq Unified Manager, published on 18 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24928 and fix it if it is affected.\n\nWhat it is: CVE-2025-24928 is a high-severity memory corruption vulnerability in Netapp Active Iq Unified Manager, published on 18 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24928 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- java (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461\n- java-min (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461\n- jre (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24928/ (Markdown: https://insights.sbomify.com/CVE-2025-24928/index.md)","id":"CVE-2025-24928","markdown":"https://insights.sbomify.com/CVE-2025-24928/index.md","name":"CVE-2025-24928","record":{"aliases":["ALPINE-CVE-2025-24928","AZL-56931","AZL-57031","BELL-CVE-2025-24928","BIT-java-2025-24928","BIT-java-min-2025-24928","BIT-jre-2025-24928","CLSA-2025-1742918628","DEBIAN-CVE-2025-24928","ECHO-aab7-9325-81a4","GHSA-fgfv-9xqc-v794","JLSEC-2025-87","MINI-fm7f-wx8j-5r6j","MINI-r58f-vr8w-96ch","ROOT-OS-ALPINE-315-CVE-2025-24928","UBUNTU-CVE-2025-24928","openSUSE-SU-2025:14999-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"XML parsing library","requires_auth":"none","summary":"A stack-based buffer overflow in libxml2 allows attackers to execute arbitrary code or cause denial of service via malicious DTD validation.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"active_iq_unified_manager","vendor":"netapp"},{"product":"h300s_firmware","vendor":"netapp"},{"product":"h410c_firmware","vendor":"netapp"},{"product":"h410s_firmware","vendor":"netapp"},{"product":"h500s_firmware","vendor":"netapp"},{"product":"h700s_firmware","vendor":"netapp"},{"product":"hci_compute_node","vendor":"netapp"},{"product":"manageability_software_development_kit","vendor":"netapp"},{"product":"ontap","vendor":"netapp"},{"product":"solidfire_\\\u0026_hci_management_node","vendor":"netapp"},{"product":"libxml2","vendor":"xmlsoft"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-121","name":"Stack-based Buffer Overflow"}],"description":"libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a stack-based buffer overflow in xmlSnprintfElements in valid.c. To exploit this, DTD validation must occur for an untrusted document or untrusted DTD. NOTE: this is similar to CVE-2017-9047.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in libxml2","id":"CVE-2025-24928","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"netapp:active_iq_unified_manager","products":["netapp:active_iq_unified_manager","netapp:h300s_firmware","netapp:h410c_firmware","netapp:h410s_firmware","netapp:h500s_firmware","netapp:h700s_firmware","netapp:hci_compute_node","netapp:solidfire_\\\u0026_hci_management_node","xmlsoft:libxml2"],"type":"memory_corruption","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"SO_REUSEPORT_LB breaks connect(2) for UDP sockets","id":"CVE-2025-24934"},"packages":[{"ecosystem":"Bitnami","fixed":["1.8.0","8.0.461"],"introduced":["0","1.9.0"],"last_affected":[],"package":"java","purl":"pkg:bitnami/java","source":"BIT-java-2025-24928"},{"ecosystem":"Bitnami","fixed":["1.8.0","8.0.461"],"introduced":["0","1.9.0"],"last_affected":[],"package":"java-min","purl":"pkg:bitnami/java-min","source":"BIT-java-min-2025-24928"},{"ecosystem":"Bitnami","fixed":["1.8.0","8.0.461"],"introduced":["0","1.9.0"],"last_affected":[],"package":"jre","purl":"pkg:bitnami/jre","source":"BIT-jre-2025-24928"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.3.2-1.1"],"introduced":["0"],"last_affected":[],"package":"python-lxml","purl":"pkg:rpm/opensuse/python-lxml\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14999-1"}],"prev":{"headline":"applications_settings has a missing release of memory vulnerability","id":"CVE-2025-24925"},"products":["libxml2"],"published":"2025-02-18","related":[{"cvss_score":9.8,"headline":"Spring Security authorization rules can be bypassed via forward or include dispatcher types","id":"CVE-2022-31692","kev_date_added":null,"published":"2022-10-31"},{"cvss_score":9.8,"headline":"Use after free in systemd-resolved","id":"CVE-2022-2526","kev_date_added":null,"published":"2022-09-09"},{"cvss_score":9.8,"headline":"Authorization bypass in Spring Security","id":"CVE-2022-22978","kev_date_added":null,"published":"2022-05-19"},{"cvss_score":9.8,"headline":"Code injection in Node","id":"CVE-2021-22931","kev_date_added":null,"published":"2021-08-16"},{"cvss_score":9,"headline":"Code injection in Java","id":"CVE-2018-2938","kev_date_added":null,"published":"2018-07-18"},{"cvss_score":8.3,"headline":"Code injection in Java","id":"CVE-2018-2941","kev_date_added":null,"published":"2018-07-18"},{"cvss_score":8.3,"headline":"Code injection in Java","id":"CVE-2018-2942","kev_date_added":null,"published":"2018-07-18"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["xmlsoft"]},"summary":"A stack-based buffer overflow in libxml2 allows attackers to execute arbitrary code or cause denial of service via malicious DTD validation.","url":"https://insights.sbomify.com/CVE-2025-24928/"}