# CVE-2025-24928: Memory corruption in libxml2

> A stack-based buffer overflow in libxml2 allows attackers to execute arbitrary code or cause denial of service via malicious DTD validation.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2025
- **Updated:** 26 Feb 2026
- **Also known as:** ALPINE-CVE-2025-24928, AZL-56931, AZL-57031, BELL-CVE-2025-24928, BIT-java-2025-24928, BIT-java-min-2025-24928, BIT-jre-2025-24928, CLSA-2025-1742918628, DEBIAN-CVE-2025-24928, ECHO-aab7-9325-81a4, GHSA-fgfv-9xqc-v794, JLSEC-2025-87, MINI-fm7f-wx8j-5r6j, MINI-r58f-vr8w-96ch, ROOT-OS-ALPINE-315-CVE-2025-24928, UBUNTU-CVE-2025-24928, openSUSE-SU-2025:14999-1

## What is CVE-2025-24928?

CVE-2025-24928 is a high-severity memory corruption vulnerability in Netapp Active Iq Unified Manager, published on 18 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a stack-based buffer overflow in xmlSnprintfElements in valid.c. To exploit this, DTD validation must occur for an untrusted document or untrusted DTD. NOTE: this is similar to CVE-2017-9047.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2025-24928?

3 open source packages ship an affected version, including java, java-min and jre. It affects 11 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.8.0, 8.0.461 |
| `java-min` | Bitnami | All versions | 1.8.0, 8.0.461 |
| `jre` | Bitnami | All versions | 1.8.0, 8.0.461 |
| `python-lxml` | openSUSE:Tumbleweed | All versions | 5.3.2-1.1 |

Products: Netapp Active Iq Unified Manager, Netapp H300s Firmware, Netapp H410c Firmware, Netapp H410s Firmware, Netapp H500s Firmware, Netapp H700s Firmware, Netapp Hci Compute Node, Netapp Manageability Software Development Kit, Netapp Ontap, Netapp Solidfire \& Hci Management Node, Xmlsoft Libxml2.

## How do I fix CVE-2025-24928?

Upgrade java to a fixed version for your release line: 1.8.0 or 8.0.461.

## Is CVE-2025-24928 being exploited?

There is no known exploitation of CVE-2025-24928 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24928 and fix it if it is affected.

What it is: CVE-2025-24928 is a high-severity memory corruption vulnerability in Netapp Active Iq Unified Manager, published on 18 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24928 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461
- java-min (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461
- jre (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24928/ (Markdown: https://insights.sbomify.com/CVE-2025-24928/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24928
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24928
- OSV: https://osv.dev/vulnerability/CVE-2025-24928

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24928/
Summaries are generated and may contain mistakes; the official description above is the record.
