# CVE-2025-24961: Insecure path traversal in filesystem and filesystem-nio2 storage backends in org.gaul S3Proxy


- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 3 Feb 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-2ccp-vqmv-4r4x

## What is CVE-2025-24961?

CVE-2025-24961 is a medium-severity vulnerability in gaul s3proxy, published on 3 Feb 2025. 

### Official description

org.gaul S3Proxy implements the S3 API and proxies requests. Users of the filesystem and filesystem-nio2 storage backends could unintentionally expose local files to users. This issue has been addressed in version 2.6.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-24961?

2 open source packages ship an affected version, including org.gaul:s3proxy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.gaul:s3proxy` | Maven | All versions | 2.6.0 |
| `org.gaul:s3proxy` | Maven | All versions | 2.6.0 |

## How do I fix CVE-2025-24961?

Upgrade org.gaul:s3proxy to 2.6.0 or later.

## Is CVE-2025-24961 being exploited?

There is no known exploitation of CVE-2025-24961 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24961 and fix it if it is affected.

What it is: CVE-2025-24961 is a medium-severity vulnerability in gaul s3proxy, published on 3 Feb 2025. 
Exploitation: There is no known exploitation of CVE-2025-24961 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.gaul:s3proxy (Maven): affected all versions; fixed in 2.6.0
- org.gaul:s3proxy (Maven): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24961/ (Markdown: https://insights.sbomify.com/CVE-2025-24961/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24961
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24961
- OSV: https://osv.dev/vulnerability/CVE-2025-24961

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24961/
Summaries are generated and may contain mistakes; the official description above is the record.
