# CVE-2025-24964: Remote Code Execution when accessing a malicious website while Vitest API server is listening

> Attackers can execute arbitrary code via Cross-site WebSocket Hijacking if the Vitest API server is enabled and lacks origin checks.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Feb 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-9crc-q9x8-hgqq, ROOT-APP-NPM-CVE-2025-24964

## What is CVE-2025-24964?

CVE-2025-24964 is a critical vulnerability in vitest-dev vitest, published on 4 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Vitest is a testing framework powered by Vite. Affected versions are subject to arbitrary remote Code Execution when accessing a malicious website while Vitest API server is listening by Cross-site WebSocket hijacking (CSWSH) attacks. When `api` option is enabled (Vitest UI enables it), Vitest starts a WebSocket server. This WebSocket server did not check Origin header and did not have any authorization mechanism and was vulnerable to CSWSH attacks. This WebSocket server has `saveTestFile` API that can edit a test file and `rerun` API that can rerun the tests. An attacker can execute arbitrary code by injecting a code in a test file by the `saveTestFile` API and then running that file by calling the `rerun` API. This vulnerability can result in remote code execution for users that are using Vitest serve API. This issue has been patched in versions 1.6.1, 2.1.9 and 3.0.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-1385 (Missing Origin Validation in WebSockets)

## Which versions are affected by CVE-2025-24964?

8 open source packages ship an affected version, including vitest. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vitest` | npm | All versions to 0.0.125 | None |
| `vitest` | npm | All versions to 0.0.125 | None |
| `vitest` | npm | From 1.0.0 | 1.6.1 |
| `vitest` | npm | From 1.0.0 | 1.6.1 |
| `vitest` | npm | From 2.0.0 | 2.1.9 |
| `vitest` | npm | From 2.0.0 | 2.1.9 |
| `vitest` | npm | From 3.0.0 | 3.0.5 |
| `vitest` | npm | From 3.0.0 | 3.0.5 |

Products: Vitest.dev Vitest.

## How do I fix CVE-2025-24964?

Upgrade vitest to a fixed version for your release line: 1.6.1, 2.1.9 or 3.0.5.

## Is CVE-2025-24964 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24964 exists.

## Other vulnerabilities in vitest-dev vitest

- [CVE-2026-47429](https://insights.sbomify.com/CVE-2026-47429/): Vitest: Arbitrary file can be read and executed when Vitest UI server is listening (critical 9.8)
- [CVE-2025-24963](https://insights.sbomify.com/CVE-2025-24963/): Browser mode serves arbitrary files in vitest (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24964 and fix it if it is affected.

What it is: CVE-2025-24964 is a critical vulnerability in vitest-dev vitest, published on 4 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24964 exists.

Affected packages and fixed versions:
- vitest (npm): affected all versions up to 0.0.125; no fix listed
- vitest (npm): affected all versions up to 0.0.125; no fix listed
- vitest (npm): affected from 1.0.0; fixed in 1.6.1
- vitest (npm): affected from 1.0.0; fixed in 1.6.1
- vitest (npm): affected from 2.0.0; fixed in 2.1.9
- vitest (npm): affected from 2.0.0; fixed in 2.1.9
- vitest (npm): affected from 3.0.0; fixed in 3.0.5
- vitest (npm): affected from 3.0.0; fixed in 3.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24964/ (Markdown: https://insights.sbomify.com/CVE-2025-24964/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24964
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24964
- OSV: https://osv.dev/vulnerability/CVE-2025-24964

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24964/
Summaries are generated and may contain mistakes; the official description above is the record.
