# CVE-2025-24970: SslHandler doesn't correctly validate packets which can lead to native crash when using native SSLEngine

> A crafted packet can cause a native crash in Netty's SslHandler when using the native SSLEngine, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2025
- **Updated:** 16 Apr 2025
- **Also known as:** CLEANSTART-2026-BV69043, CLEANSTART-2026-ZA32315, CLSA-2025-1754611416, ECHO-1d8b-58fb-4712, GHSA-4g8c-wm8x-jfhw, MINI-2863-rqmc-2fqj, MINI-32cg-hcfj-v739, MINI-3ch5-j3fv-cg29, MINI-3qxq-gw25-4gg3, MINI-5pvm-2qhq-4hfp, MINI-73qh-2hq7-vr8m, MINI-7cmc-74g7-46gx, MINI-84qr-vgx6-hjpr, MINI-cc9v-c3w2-wf9h, MINI-f8j9-3mj3-qqjp, MINI-gw9j-vg66-x3jq, MINI-r4w8-wrjh-c595, MINI-v82w-gc28-7j8f, MINI-w7h6-5j3h-rwhw, MINI-wpxw-5237-hp65, MINI-xpx9-x3x2-424m, ROOT-APP-MAVEN-CVE-2025-24970, UBUNTU-CVE-2025-24970

## What is CVE-2025-24970?

CVE-2025-24970 is a high-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 10 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty, an asynchronous, event-driven network application framework, has a vulnerability starting in version 4.1.91.Final and prior to version 4.1.118.Final. When a special crafted packet is received via SslHandler it doesn't correctly handle validation of such a packet in all cases which can lead to a native crash. Version 4.1.118.Final contains a patch. As workaround its possible to either disable the usage of the native SSLEngine or change the code manually.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-24970?

2 open source packages ship an affected version, including io.netty:netty-handler. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-handler` | Maven | From 4.1.91.Final | 4.1.118.Final |
| `io.netty:netty-handler` | Maven | From 4.1.91.Final | 4.1.118.Final |

Products: Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netty Netty.

## How do I fix CVE-2025-24970?

Upgrade io.netty:netty-handler to 4.1.118.Final or later.

## Is CVE-2025-24970 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24970 exists.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24970 and fix it if it is affected.

What it is: CVE-2025-24970 is a high-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 10 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24970 exists.

Affected packages and fixed versions:
- io.netty:netty-handler (Maven): affected from 4.1.91.Final; fixed in 4.1.118.Final
- io.netty:netty-handler (Maven): affected from 4.1.91.Final; fixed in 4.1.118.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24970/ (Markdown: https://insights.sbomify.com/CVE-2025-24970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24970
- OSV: https://osv.dev/vulnerability/CVE-2025-24970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24970/
Summaries are generated and may contain mistakes; the official description above is the record.
