CVE-2025-24975 Firebird Non-Authorized Access to Encrypted Database Using Execute Statement on External
Attackers can access encrypted databases without keys or cause server crashes due to improper connection pool verification in Firebird.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-24975?
CVE-2025-24975 is a high-severity authentication bypass vulnerability in FirebirdSQL firebird, published on 15 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Firebird is a relational database. Prior to snapshot versions 4.0.6.3183, 5.0.2.1610, and 6.0.0.609, Firebird is vulnerable if ExtConnPoolSize is not set equal to 0. If connections stored in ExtConnPool are not verified for presence and suitability of the CryptCallback interface is used when created versus what is available could result in a segfault in the server process. Encrypted databases, accessed by execute statement on external, may be accessed later by an attachment missing a key to that database. In a case when execute statement are chained, segfault may happen. Additionally, the segfault may affect unencrypted databases. This issue has been patched in snapshot versions 4.0.6.3183, 5.0.2.1610, and 6.0.0.609 and point releases 4.0.6 and 5.0.2. A workaround for this issue involves setting ExtConnPoolSize equal to 0 in firebird.conf.
Weakness: CWE-754
Which versions are affected by CVE-2025-24975?
It affects 1 product.
Products include Firebirdsql Firebird.
How do I fix CVE-2025-24975?
Apply the vendor's patch.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-24975 being exploited?
There is no known exploitation of CVE-2025-24975 in the wild and no public exploit code.
Other vulnerabilities in FirebirdSQL firebird
Sources
Also known as DEBIAN-CVE-2025-24975, GHSA-fx9r-rj68-7p69, UBUNTU-CVE-2025-24975.