{"answers":{"affected":"1 open source package ship an affected version, including pycti. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-24977 in the wild and no public exploit code.","fix":"Upgrade pycti to 6.4.11 or later.","what":"CVE-2025-24977 is a critical code injection vulnerability in OpenCTI-Platform opencti, published on 5 May 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24977 and fix it if it is affected.\n\nWhat it is: CVE-2025-24977 is a critical code injection vulnerability in OpenCTI-Platform opencti, published on 5 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24977 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pycti (PyPI): affected from 6.4.8; fixed in 6.4.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24977/ (Markdown: https://insights.sbomify.com/CVE-2025-24977/index.md)","id":"CVE-2025-24977","markdown":"https://insights.sbomify.com/CVE-2025-24977/index.md","name":"CVE-2025-24977","record":{"aliases":["GHSA-mf88-g2wq-p7qm","PYSEC-2025-179"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCTI platform","requires_auth":"high_privilege","summary":"Users with customization management rights can execute arbitrary commands and access secrets via web hooks, requiring an upgrade to OpenCTI.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opencti","vendor":"citeum"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"OpenCTI is an open cyber threat intelligence (CTI) platform. Prior to version 6.4.11 any user with the capability `manage customizations` can execute commands on the underlying infrastructure where OpenCTI is hosted and can access internal server side secrets by misusing the web-hooks. Since the malicious user gets a root shell inside a container this opens up the the infrastructure environment for further attacks and exposures. Version 6.4.11 fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenCTI has remote code execution and sensitive secrets exposed through web hook","id":"CVE-2025-24977","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Pimcore Admin Classic Bundle allows user enumeration","id":"CVE-2025-24980"},"packages":[{"ecosystem":"PyPI","fixed":["6.4.11"],"introduced":["6.4.8"],"last_affected":[],"package":"pycti","purl":"pkg:pypi/pycti","source":"PYSEC-2025-179"}],"prev":{"headline":"Distribution's token authentication allows attacker to inject an untrusted signing key in a JWT","id":"CVE-2025-24976"},"products":["opencti"],"published":"2025-05-05","related":[{"cvss_score":9.8,"headline":"OpenCTI privilege escalation and unauthenticated access via default admin account","id":"CVE-2026-27960","kev_date_added":null,"published":"2026-05-05"},{"cvss_score":9.1,"headline":"OpenCTI affected by RCE via notifier template","id":"CVE-2026-39980","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":8.3,"headline":"OpenCTI Authenticated Privilege Escalation","id":"CVE-2024-26139","kev_date_added":null,"published":"2024-05-23"},{"cvss_score":8.1,"headline":"OpenCTI's lack of Rate Limit lead to OTP brute forcing","id":"CVE-2024-45404","kev_date_added":null,"published":"2024-12-11"},{"cvss_score":7.7,"headline":"OpenCTI has a Semi-Blind SSRF via Unvalidated External URL in Data Ingestion Feature","id":"CVE-2026-21887","kev_date_added":null,"published":"2026-03-12"},{"cvss_score":7.6,"headline":"OpenCTI vulnerable to Denial of Service through web hook","id":"CVE-2025-26621","kev_date_added":null,"published":"2025-05-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-05","vendors":["OpenCTI-Platform"]},"summary":"Users with customization management rights can execute arbitrary commands and access secrets via web hooks, requiring an upgrade to OpenCTI.","url":"https://insights.sbomify.com/CVE-2025-24977/"}