CVE-2025-2498 Insufficient Granularity of Access Control in GitLab

Low 3.1 Published Updated

Attackers can bypass IP restrictions to view assigned issues from restricted groups in GitLab EE, requiring specific conditions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-2498?

CVE-2025-2498 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 13 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An improper access control in Gitlab EE affecting all versions from 12.0 prior to 18.0.6, 18.1 prior to 18.1.4, and 18.2 prior to 18.2.2 that under certain conditions could have allowed users to view assigned issues from restricted groups by bypassing IP restrictions.

Weakness: CWE-1220

Which versions are affected by CVE-2025-2498?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.0.018.0.6, 18.1.4, 18.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-2498?

Upgrade gitlab to a fixed version for your release line: 18.0.6, 18.1.4 or 18.2.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-2498 being exploited?

There is no known exploitation of CVE-2025-2498 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-2498, GHSA-vcvr-9mwv-w2g3, UBUNTU-CVE-2025-2498.

Is CVE-2025-2498 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free