{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24980 exists.","fix":"Upgrade pimcore/admin-ui-classic-bundle to 1.7.4 or later.","what":"CVE-2025-24980 is a medium-severity vulnerability in pimcore admin-ui-classic-bundle, published on 7 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24980 and fix it if it is affected.\n\nWhat it is: CVE-2025-24980 is a medium-severity vulnerability in pimcore admin-ui-classic-bundle, published on 7 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24980 exists.\n\nAffected packages and fixed versions:\n- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.4\n- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24980/ (Markdown: https://insights.sbomify.com/CVE-2025-24980/index.md)","id":"CVE-2025-24980","markdown":"https://insights.sbomify.com/CVE-2025-24980/index.md","name":"CVE-2025-24980","record":{"aliases":["GHSA-vr5f-php7-rg24"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Pimcore admin bundle","requires_auth":"none","summary":"Attackers can enumerate valid user accounts via the forgot password function due to distinct error messages, requiring an upgrade to the admin bundle.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"admin_classic_bundle","vendor":"pimcore"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-204","name":"Observable Response Discrepancy"}],"description":"pimcore/admin-ui-classic-bundle provides a Backend UI for Pimcore. In affected versions an error message discloses existing accounts and leads to user enumeration on the target via \"Forgot password\" function. No generic error message has been implemented. This issue has been addressed in version 1.7.4 and all users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Pimcore Admin Classic Bundle allows user enumeration","id":"CVE-2025-24980","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Parsed HTML anchor links in Markdown provided to parseMarkdown can result in XSS in @nuxtjs/mdc","id":"CVE-2025-24981"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":null,"source":"GHSA-vr5f-php7-rg24"},{"ecosystem":"Packagist","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":"pkg:composer/pimcore/admin-ui-classic-bundle","source":"GHSA-vr5f-php7-rg24"}],"prev":{"headline":"OpenCTI has remote code execution and sensitive secrets exposed through web hook","id":"CVE-2025-24977"},"products":["admin-ui-classic-bundle"],"published":"2025-02-07","related":[{"cvss_score":8.8,"headline":"Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip","id":"CVE-2024-23646","kev_date_added":null,"published":"2024-01-24"},{"cvss_score":8.8,"headline":"Pimcore Admin Classic Bundle host header injection in the password reset","id":"CVE-2024-23648","kev_date_added":null,"published":"2024-01-24"},{"cvss_score":8.5,"headline":"Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls","id":"CVE-2023-49075","kev_date_added":null,"published":"2023-11-28"},{"cvss_score":8.1,"headline":"Pimcore Host Header Injection in user invitation link","id":"CVE-2024-25625","kev_date_added":null,"published":"2024-02-19"},{"cvss_score":6.5,"headline":"Pimcore Admin Classic Bundle permissions are not getting checked when working with tags","id":"CVE-2024-24822","kev_date_added":null,"published":"2024-02-07"},{"cvss_score":6.3,"headline":"Pimcore vulnerable to disclosure of system and database information behind /admin firewall","id":"CVE-2024-41109","kev_date_added":null,"published":"2024-07-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-16","vendors":["pimcore"]},"summary":"Attackers can enumerate valid user accounts via the forgot password function due to distinct error messages, requiring an upgrade to the admin bundle.","url":"https://insights.sbomify.com/CVE-2025-24980/"}