# CVE-2025-24980: Pimcore Admin Classic Bundle allows user enumeration

> Attackers can enumerate valid user accounts via the forgot password function due to distinct error messages, requiring an upgrade to the admin bundle.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2025
- **Updated:** 16 Jan 2026
- **Also known as:** GHSA-vr5f-php7-rg24

## What is CVE-2025-24980?

CVE-2025-24980 is a medium-severity vulnerability in pimcore admin-ui-classic-bundle, published on 7 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pimcore/admin-ui-classic-bundle provides a Backend UI for Pimcore. In affected versions an error message discloses existing accounts and leads to user enumeration on the target via "Forgot password" function. No generic error message has been implemented. This issue has been addressed in version 1.7.4 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2025-24980?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.7.4 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.7.4 |

Products: Pimcore Admin Classic Bundle.

## How do I fix CVE-2025-24980?

Upgrade pimcore/admin-ui-classic-bundle to 1.7.4 or later.

## Is CVE-2025-24980 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24980 exists.

## Other vulnerabilities in pimcore admin-ui-classic-bundle

- [CVE-2024-23646](https://insights.sbomify.com/CVE-2024-23646/): Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip (high 8.8)
- [CVE-2024-23648](https://insights.sbomify.com/CVE-2024-23648/): Pimcore Admin Classic Bundle host header injection in the password reset (high 8.8)
- [CVE-2023-49075](https://insights.sbomify.com/CVE-2023-49075/): Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls (high 8.5)
- [CVE-2024-25625](https://insights.sbomify.com/CVE-2024-25625/): Pimcore Host Header Injection in user invitation link (high 8.1)
- [CVE-2024-24822](https://insights.sbomify.com/CVE-2024-24822/): Pimcore Admin Classic Bundle permissions are not getting checked when working with tags (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24980 and fix it if it is affected.

What it is: CVE-2025-24980 is a medium-severity vulnerability in pimcore admin-ui-classic-bundle, published on 7 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24980 exists.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.4
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24980/ (Markdown: https://insights.sbomify.com/CVE-2025-24980/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24980
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24980
- OSV: https://osv.dev/vulnerability/CVE-2025-24980

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24980/
Summaries are generated and may contain mistakes; the official description above is the record.
