# CVE-2025-24986: Azure Promptflow Remote Code Execution Vulnerability

> An attacker can execute arbitrary code remotely due to improper isolation in Azure PromptFlow libraries.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2025
- **Updated:** 13 Feb 2026
- **Also known as:** GHSA-gprr-v9f2-px3c, PYSEC-2026-1804, PYSEC-2026-2968

## What is CVE-2025-24986?

CVE-2025-24986 is a medium-severity code injection vulnerability in Microsoft Azure promptflow-core, published on 11 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper isolation or compartmentalization in Azure PromptFlow allows an unauthorized attacker to execute code over a network.

Weakness: CWE-653 (Improper Isolation or Compartmentalization)

## Which versions are affected by CVE-2025-24986?

6 open source packages ship an affected version, including promptflow-core and promptflow-tools. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `promptflow-core` | PyPI | All versions | 1.17.2 |
| `promptflow-core` | PyPI | All versions | 1.17.2 |
| `promptflow-core` | PyPI | All versions | 1.17.2 |
| `promptflow-tools` | PyPI | All versions | 1.6.0 |
| `promptflow-tools` | PyPI | All versions | 1.6.0 |
| `promptflow-tools` | PyPI | All versions | 1.6.0 |

Products: Microsoft Azure Promptflow Core, Microsoft Azure Promptflow Tools.

## How do I fix CVE-2025-24986?

Upgrade promptflow-core to 1.17.2 or later.

## Is CVE-2025-24986 being exploited?

There is no known exploitation of CVE-2025-24986 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24986 and fix it if it is affected.

What it is: CVE-2025-24986 is a medium-severity code injection vulnerability in Microsoft Azure promptflow-core, published on 11 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24986 in the wild and no public exploit code.

Affected packages and fixed versions:
- promptflow-core (PyPI): affected all versions; fixed in 1.17.2
- promptflow-core (PyPI): affected all versions; fixed in 1.17.2
- promptflow-core (PyPI): affected all versions; fixed in 1.17.2
- promptflow-tools (PyPI): affected all versions; fixed in 1.6.0
- promptflow-tools (PyPI): affected all versions; fixed in 1.6.0
- promptflow-tools (PyPI): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24986/ (Markdown: https://insights.sbomify.com/CVE-2025-24986/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24986
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24986
- OSV: https://osv.dev/vulnerability/CVE-2025-24986

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24986/
Summaries are generated and may contain mistakes; the official description above is the record.
