CVE-2025-25068 Bypassing MFA Enforcement on Plugin Endpoints

High 7.5 Published Updated

Authenticated attackers can bypass Multi-Factor Authentication enforcement on plugin endpoints by accessing specific API routes.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-25068?

CVE-2025-25068 is a high-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 21 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8, 10.5.x <= 10.5.0 fail to enforce MFA on plugin endpoints, which allows authenticated attackers to bypass MFA protections via API requests to plugin-specific routes.

Weakness: CWE-306

Which versions are affected by CVE-2025-25068?

13 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoFrom 10.3.010.3.4
github.com/mattermost/mattermost/server/v8 GoFrom 10.3.010.3.4
github.com/mattermost/mattermost/server/v8 GoFrom 10.4.010.4.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.4.010.4.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.1
7 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.1
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.9
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.9
mattermost BitnamiFrom 9.11.010.0.0, 10.5.1
github.com/mattermost/mattermost-server GoFrom 9.11.0+incompatible9.11.9+incompatible, 10.3.4+incompatible, 10.4.3+incompatible, 10.5.1+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-25068?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 10.3.4, 10.4.3, 10.5.1 or 9.11.9.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-25068 being exploited?

There is no known exploitation of CVE-2025-25068 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as BIT-mattermost-2025-25068, GHSA-72qv-j8vr-xvfv, GO-2025-3551.

Is CVE-2025-25068 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free