CVE-2025-25182 Stroom Authentication/Authorization Bypass when using AWS ALB

Critical 9.4 Published Updated

Attackers can bypass authentication and potentially execute code via SSRF if Stroom is configured with AWS ALB but accessible directly.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-25182?

CVE-2025-25182 is a critical authentication bypass vulnerability in gchq stroom, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Stroom is a data processing, storage and analysis platform. A vulnerability exists starting in version 7.2-beta.53 and prior to versions 7.2.24, 7.3-beta.22, 7.4.4, and 7.5-beta.2 that allows authentication bypass to a Stroom system when configured with ALB and installed in a way that the application is accessible not through the ALB itself. This vulnerability may also allow for server-side request forgery which may lead to code execution or further privileges escalations when using the AWS metadata URL. This scenario assumes that Stroom must be configured to use ALB Authentication integration and the application is network accessible. The vulnerability has been fixed in versions 7.2.24, 7.3-beta.22, 7.4.4, and 7.5-beta.2.

Weakness: CWE-290

Which versions are affected by CVE-2025-25182?

How do I fix CVE-2025-25182?

No fix has been published for CVE-2025-25182 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-25182 being exploited?

There is no known exploitation of CVE-2025-25182 in the wild and no public exploit code.

Sources

Also known as GHSA-x489-xx2m-vc43.

Is CVE-2025-25182 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free