# CVE-2025-25182: Stroom Authentication/Authorization Bypass when using AWS ALB

> Attackers can bypass authentication and potentially execute code via SSRF if Stroom is configured with AWS ALB but accessible directly.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Feb 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-x489-xx2m-vc43

## What is CVE-2025-25182?

CVE-2025-25182 is a critical authentication bypass vulnerability in gchq stroom, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Stroom is a data processing, storage and analysis platform. A vulnerability exists starting in version 7.2-beta.53 and prior to versions 7.2.24, 7.3-beta.22, 7.4.4, and 7.5-beta.2 that allows authentication bypass to a Stroom system when configured with ALB and installed in a way that the application is accessible not through the ALB itself. This vulnerability may also allow for server-side request forgery which may lead to code execution or further privileges escalations when using the AWS metadata URL. This scenario assumes that Stroom must be configured to use ALB Authentication integration and the application is network accessible. The vulnerability has been fixed in versions 7.2.24, 7.3-beta.22, 7.4.4, and 7.5-beta.2.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2025-25182?


## How do I fix CVE-2025-25182?

No fix has been published for CVE-2025-25182 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-25182 being exploited?

There is no known exploitation of CVE-2025-25182 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-25182 and fix it if it is affected.

What it is: CVE-2025-25182 is a critical authentication bypass vulnerability in gchq stroom, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-25182 in the wild and no public exploit code.

Affected product: gchq stroom. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-25182/ (Markdown: https://insights.sbomify.com/CVE-2025-25182/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-25182
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-25182
- OSV: https://osv.dev/vulnerability/CVE-2025-25182

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-25182/
Summaries are generated and may contain mistakes; the official description above is the record.
